blob: 833fdbcc5875324b4c90d953c292b0c4c49ba32a [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A generic, spec-compliant, thorough implementation of the OAuth request-signing logic"
2HOMEPAGE = "https://github.com/idan/oauthlib"
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=abd2675e944a2011aed7e505290ba482"
6
Patrick Williams2390b1b2022-11-03 13:47:49 -05007SRC_URI[sha256sum] = "9859c40929662bec5d64f34d01c99e093149682a3f38915dc0655d5a633dd918"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008
9inherit pypi setuptools3
10
11# The following configs & dependencies are from setuptools extras_require.
12# These dependencies are optional, hence can be controlled via PACKAGECONFIG.
13# The upstream names may not correspond exactly to bitbake package names.
14#
15# Uncomment this line to enable all the optional features.
16#PACKAGECONFIG ?= "test signedtoken signals rsa"
Patrick Williams39653562024-03-01 08:54:02 -060017PACKAGECONFIG[test] = ",,,python3-blinker python3-cryptography python3-pytest python3-pyjwt"
18PACKAGECONFIG[signedtoken] = ",,,python3-cryptography python3-pyjwt"
19PACKAGECONFIG[signals] = ",,,python3-blinker"
20PACKAGECONFIG[rsa] = ",,,python3-cryptography"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000021
Patrick Williams39653562024-03-01 08:54:02 -060022RDEPENDS:${PN} += "python3-core python3-crypt python3-datetime python3-json python3-logging python3-math python3-netclient python3-unittest"