Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "A generic, spec-compliant, thorough implementation of the OAuth request-signing logic" |
| 2 | HOMEPAGE = "https://github.com/idan/oauthlib" |
| 3 | |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=abd2675e944a2011aed7e505290ba482" |
| 6 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "9859c40929662bec5d64f34d01c99e093149682a3f38915dc0655d5a633dd918" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 8 | |
| 9 | inherit pypi setuptools3 |
| 10 | |
| 11 | # The following configs & dependencies are from setuptools extras_require. |
| 12 | # These dependencies are optional, hence can be controlled via PACKAGECONFIG. |
| 13 | # The upstream names may not correspond exactly to bitbake package names. |
| 14 | # |
| 15 | # Uncomment this line to enable all the optional features. |
| 16 | #PACKAGECONFIG ?= "test signedtoken signals rsa" |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 17 | PACKAGECONFIG[test] = ",,,python3-blinker python3-cryptography python3-pytest python3-pyjwt" |
| 18 | PACKAGECONFIG[signedtoken] = ",,,python3-cryptography python3-pyjwt" |
| 19 | PACKAGECONFIG[signals] = ",,,python3-blinker" |
| 20 | PACKAGECONFIG[rsa] = ",,,python3-cryptography" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 21 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 22 | RDEPENDS:${PN} += "python3-core python3-crypt python3-datetime python3-json python3-logging python3-math python3-netclient python3-unittest" |