Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Tools for testing processes." |
| 5 | HOMEPAGE = "https://github.com/ionelmc/python-process-tests" |
| 6 | LICENSE = "BSD-2-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=aea36d49429f53e06868d87cd9d62349" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "e5d57dea7161251e91cadb84bf3ecc85275fb121fd478e579f800777b1d424bd" |
| 10 | |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | RDEPENDS:${PN} += "python3-core" |
| 14 | |
| 15 | BBCLASSEXTEND = "native nativesdk" |
| 16 | |
| 17 | RDEPENDS:${PN} += " \ |
| 18 | python3-io \ |
| 19 | python3-logging \ |
| 20 | python3-unittest \ |
| 21 | " |