Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "A collection of ASN.1-based protocols modules." |
| 2 | DESCRIPTION = "A collection of ASN.1 modules expressed in form of pyasn1\ |
| 3 | classes. Includes protocols PDUs definition (SNMP, LDAP etc.) and various\ |
| 4 | data structures (X.509, PKCS etc.)." |
| 5 | HOMEPAGE = "https://github.com/etingof/pyasn1-modules" |
| 6 | LICENSE = "BSD-2-Clause" |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=190f79253908c986e6cacf380c3a5f6d" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 8 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "5bd01446b736eb9d31512a30d46c1ac3395d676c6f3cafa4c03eb54b9925631c" |
| 10 | |
| 11 | PYPI_PACKAGE = "pyasn1_modules" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 12 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 13 | inherit pypi ptest setuptools3 |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 15 | RDEPENDS:${PN} = "python3-pyasn1" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | |
| 17 | BBCLASSEXTEND = "native nativesdk" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
| 19 | SRC_URI += " \ |
| 20 | file://run-ptest \ |
| 21 | " |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 24 | python3-pytest \ |
| 25 | python3-unittest-automake-output \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | " |
| 27 | |
| 28 | do_install_ptest() { |
| 29 | install -d ${D}${PTEST_PATH}/tests |
| 30 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 31 | } |