blob: 246f67cb8fe956a5114a98b50b0cb52484a6c6c2 [file] [log] [blame]
Patrick Williams169d7bc2024-01-05 11:33:25 -06001SUMMARY = "Data validation using Python type hinting"
2DESCRIPTION = "Data validation and settings management using Python \
3type hints.\
4\
5Fast and extensible, Pydantic plays nicely with your linters/IDE/brain. \
6Define how data should be in pure, canonical Python 3.7+; validate it with \
7Pydantic."
8HOMEPAGE = "https://github.com/samuelcolvin/pydantic"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=09280955509d1c4ca14bae02f21d49a6"
11
12inherit pypi python_hatchling
13
Patrick Williams39653562024-03-01 08:54:02 -060014SRC_URI[sha256sum] = "e07805c4c7f5c6826e33a1d4c9d47950d7eaf34868e2690f8594d2e30241f11f"
Patrick Williams169d7bc2024-01-05 11:33:25 -060015
16DEPENDS += "python3-hatch-fancy-pypi-readme-native"
17
18RDEPENDS:${PN} += "\
19 python3-annotated-types \
20 python3-core \
21 python3-datetime \
22 python3-image \
23 python3-io \
24 python3-json \
25 python3-logging \
26 python3-netclient \
27 python3-numbers \
28 python3-profile \
29 python3-pydantic-core \
30 python3-typing-extensions \
31"
32
33inherit ptest
34SRC_URI += "file://run-ptest"
35RDEPENDS:${PN}-ptest += "\
36 python3-cloudpickle \
37 python3-dirty-equals \
38 python3-pytest \
39 python3-pytest-mock \
40 python3-unittest-automake-output \
41"
42
43do_install_ptest() {
44 cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
45 # Requires 'ruff' (python3-ruff) which we cannot build
46 # until we have Rust 1.71+ in oe-core
47 rm -f ${D}${PTEST_PATH}/tests/test_docs.py
48 # We are not trying to support mypy
49 rm -f ${D}${PTEST_PATH}/tests/test_mypy.py
50 # We are not trying to run benchmarks
51 rm -rf ${D}${PTEST_PATH}/tests/benchmarks
52}
53