blob: 21161a0e0f1922dd30f1a6bc8e703845178ae4be [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "A utility provides a fake certificate authority (CA)"
2HOMEPAGE = "https://pypi.org/project/trustme"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d5a7af1a4b73e57431e25d15a2da745a"
6
7SRC_URI[sha256sum] = "5375ad7fb427074bec956592e0d4ee2a4cf4da68934e1ba4bcf4217126bc45e6"
8
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN} += " \
16 python3-cryptography \
17 python3-datetime \
18 python3-idna \
19 python3-io \
20"
21
22RDEPENDS:${PN}-ptest += " \
Patrick Williams39653562024-03-01 08:54:02 -060023 python3-pyopenssl \
Patrick Williams73bd93f2024-02-20 08:07:48 -060024 python3-pyasn1-modules \
25 python3-pytest \
26 python3-service-identity \
27 python3-unittest-automake-output \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060028"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/tests
32 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
33 cp -rf ${S}/setup.py ${D}${PTEST_PATH}
34}