Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | DESCRIPTION = "A utility provides a fake certificate authority (CA)" |
| 2 | HOMEPAGE = "https://pypi.org/project/trustme" |
| 3 | |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d5a7af1a4b73e57431e25d15a2da745a" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "5375ad7fb427074bec956592e0d4ee2a4cf4da68934e1ba4bcf4217126bc45e6" |
| 8 | |
| 9 | inherit pypi setuptools3 ptest |
| 10 | |
| 11 | SRC_URI += " \ |
| 12 | file://run-ptest \ |
| 13 | " |
| 14 | |
| 15 | RDEPENDS:${PN} += " \ |
| 16 | python3-cryptography \ |
| 17 | python3-datetime \ |
| 18 | python3-idna \ |
| 19 | python3-io \ |
| 20 | " |
| 21 | |
| 22 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 23 | python3-pyopenssl \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 24 | python3-pyasn1-modules \ |
| 25 | python3-pytest \ |
| 26 | python3-service-identity \ |
| 27 | python3-unittest-automake-output \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 28 | " |
| 29 | |
| 30 | do_install_ptest() { |
| 31 | install -d ${D}${PTEST_PATH}/tests |
| 32 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 33 | cp -rf ${S}/setup.py ${D}${PTEST_PATH} |
| 34 | } |