blob: 38d3e1cecdf374f9594a76d60396177903ed650c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Fast, pure-Python full text indexing, search, and spell checking library."
2DESCRIPTION = "\
3Whoosh is a fast, featureful full-text indexing and searching library \
4implemented in pure Python. Programmers can use it to easily add search \
5functionality to their applications and websites. Every part of how \
6Whoosh works can be extended or replaced to meet your needs exactly."
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=05303186defc6141143629961c7c8a60"
9
10SRC_URI[md5sum] = "893433e9c0525ac043df33e6e04caab2"
11SRC_URI[sha256sum] = "e0857375f63e9041e03fedd5b7541f97cf78917ac1b6b06c1fcc9b45375dda69"
12
13PYPI_PACKAGE = "Whoosh"
14PYPI_PACKAGE_EXT = "zip"
15
16inherit ptest pypi setuptools3
17
Patrick Williams213cb262021-08-07 19:21:33 -050018RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060019 python3-email \
20 python3-multiprocessing \
21 python3-netclient \
22 python3-numbers \
23 python3-pickle \
24 python3-shell \
25 python3-stringold \
Andrew Geissler82c905d2020-04-13 13:39:40 -050026"
27
28SRC_URI += " \
29 file://run-ptest \
30"
31
Patrick Williams213cb262021-08-07 19:21:33 -050032RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060033 python3-fcntl \
34 python3-pytest \
35 python3-unittest-automake-output \
Andrew Geissler82c905d2020-04-13 13:39:40 -050036"
37
38do_install_ptest() {
39 install -d ${D}${PTEST_PATH}/tests
40 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
41}