Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 1 | SUMMARY = "Yet Another Python Profiler" |
| 2 | HOMEPAGE = "https://github.com/sumerc/yappi" |
| 3 | |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=71c208c9a4fd864385eb69ad4caa3bee" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "a9aaf72009d8c03067294151ee0470ac7a6dfa7b33baab40b198d6c1ef00430a" |
| 8 | |
| 9 | SRC_URI += " \ |
| 10 | file://run-ptest \ |
| 11 | file://0001-test_functionality-convert-line-endings-to-Unix.patch \ |
| 12 | file://0002-Fix-import-of-tests.utils-to-enable-pytest.patch \ |
| 13 | " |
| 14 | |
| 15 | inherit pypi python_setuptools_build_meta ptest |
| 16 | |
| 17 | RDEPENDS:${PN} += "\ |
| 18 | python3-datetime \ |
| 19 | python3-pickle \ |
| 20 | python3-threading \ |
| 21 | " |
| 22 | |
| 23 | RDEPENDS:${PN}-ptest += " \ |
| 24 | python3-gevent \ |
| 25 | python3-multiprocessing \ |
| 26 | python3-pytest \ |
| 27 | python3-profile \ |
| 28 | python3-unittest-automake-output \ |
| 29 | python3-zopeinterface \ |
| 30 | " |
| 31 | |
| 32 | do_install_ptest() { |
| 33 | install -d ${D}${PTEST_PATH}/tests |
| 34 | cp -rf ${S}/tests ${D}${PTEST_PATH} |
| 35 | cp -f ${S}/run_tests.py ${D}${PTEST_PATH} |
| 36 | } |
| 37 | |