Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | # This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org. |
| 2 | |
| 3 | SUMMARY = "Go programming language compiler (upstream binary for bootstrap)" |
| 4 | HOMEPAGE = " http://golang.org/" |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707" |
| 7 | |
| 8 | PROVIDES = "go-native" |
| 9 | |
| 10 | # Checksums available at https://go.dev/dl/ |
| 11 | SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}" |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 12 | SRC_URI[go_linux_amd64.sha256sum] = "f0a87f1bcae91c4b69f8dc2bc6d7e6bfcd7524fceec130af525058c0c17b1b44" |
| 13 | SRC_URI[go_linux_arm64.sha256sum] = "44781ae3b153c3b07651d93b6bc554e835a36e2d72a696281c1e4dad9efffe43" |
| 14 | SRC_URI[go_linux_ppc64le.sha256sum] = "6318a1db307c12b8afe68808bd6fae4fba1e558a85b958216096869ed506dcb3" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
| 16 | UPSTREAM_CHECK_URI = "https://golang.org/dl/" |
| 17 | UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux" |
| 18 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 19 | CVE_PRODUCT = "go" |
| 20 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 21 | S = "${WORKDIR}/go" |
| 22 | |
| 23 | inherit goarch native |
| 24 | |
| 25 | do_compile() { |
| 26 | : |
| 27 | } |
| 28 | |
| 29 | make_wrapper() { |
| 30 | rm -f ${D}${bindir}/$1 |
| 31 | cat <<END >${D}${bindir}/$1 |
| 32 | #!/bin/bash |
| 33 | here=\`dirname \$0\` |
| 34 | export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}" |
| 35 | \$here/../lib/go/bin/$1 "\$@" |
| 36 | END |
| 37 | chmod +x ${D}${bindir}/$1 |
| 38 | } |
| 39 | |
| 40 | do_install() { |
| 41 | find ${S} -depth -type d -name testdata -exec rm -rf {} + |
| 42 | |
| 43 | install -d ${D}${bindir} ${D}${libdir}/go |
| 44 | cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/ |
| 45 | |
| 46 | for f in ${S}/bin/* |
| 47 | do |
| 48 | make_wrapper `basename $f` |
| 49 | done |
| 50 | } |