Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 1 | SUMMARY = "Library providing automatic proxy configuration management" |
| 2 | DESCRIPTION = "libproxy provides interfaces to get the proxy that will be \ |
| 3 | used to access network resources. It uses various plugins to get proxy \ |
| 4 | configuration via different mechanisms (e.g. environment variables or \ |
| 5 | desktop settings)." |
| 6 | HOMEPAGE = "https://github.com/libproxy/libproxy" |
| 7 | BUGTRACKER = "https://github.com/libproxy/libproxy/issues" |
| 8 | SECTION = "libs" |
| 9 | LICENSE = "LGPL-2.1-or-later" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \ |
| 11 | file://src/libproxy/proxy.c;beginline=1;endline=20;md5=bb9a177ef1c995311070f34c5638a402 \ |
| 12 | " |
| 13 | |
| 14 | DEPENDS = "glib-2.0" |
| 15 | |
| 16 | SRC_URI = "git://github.com/libproxy/libproxy;protocol=https;branch=main" |
| 17 | SRCREV = "29d51a611f28af0bdbd51a5779cc8df264c8dcff" |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | inherit meson pkgconfig gobject-introspection vala gi-docgen |
| 21 | GIDOCGEN_MESON_OPTION = 'docs' |
| 22 | |
| 23 | PACKAGECONFIG ?= "" |
| 24 | PACKAGECONFIG[curl] = "-Dcurl=true,-Dcurl=false,curl" |
| 25 | PACKAGECONFIG[config-gnome] = "-Dconfig-gnome=true,-Dconfig-gnome=false,gsettings-desktop-schemas" |
| 26 | PACKAGECONFIG[pacrunner-duktape] = "-Dpacrunner-duktape=true,-Dpacrunner-duktape=false,duktape" |
| 27 | |
| 28 | FILES:${PN} += "${libdir}/${BPN}/${PV}/modules" |