blob: 5abeced30b27d45ba95e6f71ca35e10e14ec03e7 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "An HTTP library implementation in C"
2DESCRIPTION = "libsoup is an HTTP client/server library for GNOME. It uses GObjects \
3and the glib main loop, to integrate well with GNOME applications."
4HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
5BUGTRACKER = "https://bugzilla.gnome.org/"
6SECTION = "x11/gnome/libs"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "LGPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00008LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
9
10DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 libpsl"
11
12SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
13
14SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
Patrick Williams7784c422022-11-17 07:29:11 -060015SRC_URI[sha256sum] = "e4b77c41cfc4c8c5a035fcdc320c7bc6cfb75ef7c5a034153df1413fa1d92f13"
Andrew Geissler595f6302022-01-24 19:11:47 +000016
17CVE_PRODUCT = "libsoup"
18
19S = "${WORKDIR}/libsoup-${PV}"
20
21inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
22
23UPSTREAM_CHECK_REGEX = "libsoup-(?P<pver>2(\.(?!99)\d+)+)\.tar"
24
25GIR_MESON_ENABLE_FLAG = 'enabled'
26GIR_MESON_DISABLE_FLAG = 'disabled'
27
Andrew Geissler595f6302022-01-24 19:11:47 +000028PACKAGECONFIG ??= ""
Andrew Geissler5082cc72023-09-11 08:41:39 -040029PACKAGECONFIG[brotli] = "-Dbrotli=enabled,-Dbrotli=disabled,brotli"
30# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards
Andrew Geissler595f6302022-01-24 19:11:47 +000031PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false"
32PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5"
Andrew Geissler5082cc72023-09-11 08:41:39 -040033PACKAGECONFIG[ntlm] = "-Dntlm=enabled,-Dntlm=disabled"
34PACKAGECONFIG[sysprof] = "-Dsysprof=enabled,-Dsysprof=disabled,sysprof"
Andrew Geissler595f6302022-01-24 19:11:47 +000035
Andrew Geissler5082cc72023-09-11 08:41:39 -040036# Tell libsoup where the target ntlm_auth is installed
37do_write_config:append:class-target() {
38 cat >${WORKDIR}/soup.cross <<EOF
39[binaries]
40ntlm_auth = '${bindir}/ntlm_auth'
41EOF
42}
43EXTRA_OEMESON += "--cross-file ${WORKDIR}/soup.cross"
44
45EXTRA_OEMESON += "-Dvapi=disabled -Dtls_check=false"
Andrew Geissler595f6302022-01-24 19:11:47 +000046
47GTKDOC_MESON_OPTION = "gtk_doc"
48
49# When built without gnome support, libsoup-2.4 will contain only one shared lib
50# and will therefore become subject to renaming by debian.bbclass. Prevent
51# renaming in order to keep the package name consistent regardless of whether
52# gnome support is enabled or disabled.
53DEBIAN_NOAUTONAME:${PN} = "1"
54
55# glib-networking is needed for SSL, proxies, etc.
56RRECOMMENDS:${PN} = "glib-networking"
57
58BBCLASSEXTEND = "native nativesdk"