Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Open client for Cisco AnyConnect VPN" |
| 2 | LICENSE = "LGPLv2.1" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=243b725d71bb5df4a1e5920b344b86ad" |
| 4 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 5 | SRC_URI = " \ |
| 6 | git://git.infradead.org/users/dwmw2/openconnect.git \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | " |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 8 | SRCREV = "9d287e40c57233190a51b6434ba7345370e36f38" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 10 | DEPENDS = "vpnc libxml2 krb5 gettext-native" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | RDEPENDS_${PN} = "bash python3-core vpnc-script" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 12 | |
| 13 | PACKAGECONFIG ??= "gnutls lz4 libproxy" |
| 14 | |
| 15 | # config defaults |
| 16 | PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls," |
| 17 | PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4," |
| 18 | PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy," |
| 19 | |
| 20 | # not config defaults |
| 21 | PACKAGECONFIG[pcsc-lite] = "--with-libpcsclite,--without-libpcsclite,pcsc-lite," |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 22 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 23 | S = "${WORKDIR}/git" |
| 24 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 25 | inherit autotools pkgconfig bash-completion |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | EXTRA_OECONF += "--with-vpnc-script=${sysconfdir}/vpnc/vpnc-script \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 28 | --disable-static" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 29 | |
| 30 | do_install_append() { |
| 31 | rm ${D}/usr/libexec/openconnect/hipreport-android.sh |
| 32 | } |