Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Protocol Buffers - structured data serialisation mechanism" |
| 2 | DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \ |
| 3 | serialization format. It includes libprotobuf-c, a pure C library that \ |
| 4 | implements protobuf encoding and decoding, and protoc-c, a code generator that \ |
| 5 | converts Protocol Buffer .proto files to C descriptor code, based on the \ |
| 6 | original protoc. protobuf-c formerly included an RPC implementation; that code \ |
| 7 | has been split out into the protobuf-c-rpc project." |
| 8 | HOMEPAGE = "https://github.com/protobuf-c/protobuf-c" |
| 9 | SECTION = "console/tools" |
| 10 | LICENSE = "BSD-2-Clause" |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9f725889e0d77383e26cb42b0b62cea2" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 12 | |
| 13 | DEPENDS = "protobuf-native protobuf" |
| 14 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 15 | SRC_URI = "git://github.com/protobuf-c/protobuf-c.git;branch=next;protocol=https" |
| 16 | SRC_URI:append:class-native = " file://0001-Makefile.am-do-not-compile-the-code-which-was-genera.patch" |
| 17 | |
| 18 | SRCREV = "ba4c55f0e686e0252c451f7163ab529e4b36831a" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit autotools pkgconfig |
| 23 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 24 | export PROTOC = "${STAGING_BINDIR_NATIVE}/protoc" |
| 25 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 26 | # After several fix attempts there is still a race between generating |
| 27 | # t.test-full.pb.h and compiling cxx_generate_packed_data.c despite |
| 28 | # BUILT_SOURCES and explicit dependencies. |
| 29 | PARALLEL_MAKE = "" |
| 30 | |
| 31 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 32 | |
| 33 | FILES:${PN}-compiler = "${bindir}" |
| 34 | |
| 35 | RDEPENDS:${PN}-compiler = "protobuf-compiler" |
| 36 | RDEPENDS:${PN}-dev += "${PN}-compiler" |
| 37 | |
| 38 | BBCLASSEXTEND = "native nativesdk" |