Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Subversion (svn) version control system client" |
| 2 | HOMEPAGE = "http://subversion.apache.org" |
| 3 | SECTION = "console/network" |
| 4 | LICENSE = "Apache-2 & MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=6487ae7094d359fa90fb9c4096e52e2b" |
| 6 | |
| 7 | DEPENDS = "apr-util serf sqlite3 file lz4" |
| 8 | DEPENDS_append_class-native = " file-replacement-native" |
| 9 | |
| 10 | SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 11 | file://disable_macos.patch \ |
| 12 | file://0001-Fix-libtool-name-in-configure.ac.patch \ |
| 13 | file://serfmacro.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 14 | " |
| 15 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 16 | SRC_URI[md5sum] = "1ff249f848f834ded88536543e031975" |
| 17 | SRC_URI[sha256sum] = "3bd0b5c8e4c5175263dc9a92fd9aef94ce917e80af034f26fe5c45fde7e0f771" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 18 | |
| 19 | inherit autotools pkgconfig gettext |
| 20 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 21 | CVE_PRODUCT = "apache:subversion" |
| 22 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 23 | PACKAGECONFIG ?= "" |
| 24 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 25 | PACKAGECONFIG[boost] = "--with-boost=${RECIPE_SYSROOT}${exec_prefix},--without-boost,boost" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 26 | PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl" |
| 27 | PACKAGECONFIG[gnome-keyring] = "--with-gnome-keyring,--without-gnome-keyring,glib-2.0 gnome-keyring" |
| 28 | |
| 29 | EXTRA_OECONF = " \ |
| 30 | --with-apr=${STAGING_BINDIR_CROSS} \ |
| 31 | --with-apr-util=${STAGING_BINDIR_CROSS} \ |
| 32 | --without-apxs \ |
| 33 | --without-berkeley-db \ |
| 34 | --without-swig \ |
| 35 | --disable-keychain \ |
| 36 | --with-utf8proc=internal \ |
| 37 | ac_cv_path_RUBY=none \ |
| 38 | " |
| 39 | |
| 40 | acpaths = "-I build/ -I build/ac-macros/" |
| 41 | |
| 42 | CPPFLAGS += "-P" |
| 43 | BUILD_CPPFLAGS += "-P" |
| 44 | |
| 45 | do_configure_prepend () { |
| 46 | rm -f ${S}/libtool |
| 47 | rm -f ${S}/build/libtool.m4 ${S}/build/ltmain.sh ${S}/build/ltoptions.m4 ${S}/build/ltsugar.m4 ${S}/build/ltversion.m4 ${S}/build/lt~obsolete.m4 |
| 48 | rm -f ${S}/aclocal.m4 |
| 49 | sed -i -e 's:with_sasl="/usr/local":with_sasl="${STAGING_DIR}":' ${S}/build/ac-macros/sasl.m4 |
| 50 | } |
| 51 | |
| 52 | #| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_local/libsvn_ra_local-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| /usr/bin/ld: cannot find -lsvn_delta-1| collect2: ld returned 1 exit status| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_svn/libsvn_ra_svn-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_serf/libsvn_ra_serf-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib' |
| 53 | #| x86_64-linux-libtool: install: error: relink `libsvn_ra_serf-1.la' with the above command before installing it |
| 54 | #| x86_64-linux-libtool: install: warning: `../../subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib' |
| 55 | #| /home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/subversion-1.8.9/build-outputs.mk:1090: recipe for target 'install-serf-lib' failed |
| 56 | #| make: *** [install-serf-lib] Error 1 |
| 57 | PARALLEL_MAKEINST = "" |
| 58 | |
| 59 | RDEPENDS_${PN} = "serf" |
| 60 | |
| 61 | BBCLASSEXTEND = "native" |