Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Script-directed dynamic tracing and performance analysis tool for Linux" |
| 2 | |
| 3 | require systemtap_git.inc |
| 4 | |
| 5 | DEPENDS = "elfutils sqlite3 systemtap-native" |
| 6 | DEPENDS_class-native = "elfutils-native sqlite3-native gettext-native" |
| 7 | DEPENDS_class-nativesdk = "nativesdk-elfutils nativesdk-sqlite3 nativesdk-gettext" |
| 8 | |
| 9 | RDEPENDS_${PN} += "python bash" |
| 10 | RDEPENDS_${PN}_class-native += "python-native" |
| 11 | RDEPENDS_${PN}_class-nativesdk += "python-native" |
| 12 | |
| 13 | EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \ |
| 14 | --without-nss --without-avahi --without-dyninst \ |
| 15 | --disable-server --disable-grapher --enable-prologues \ |
| 16 | ac_cv_prog_have_javac=no \ |
| 17 | ac_cv_prog_have_jar=no " |
| 18 | |
| 19 | STAP_DOCS ?= "--disable-docs --disable-publican --disable-refdocs" |
| 20 | |
| 21 | EXTRA_OECONF += "${STAP_DOCS} " |
| 22 | |
| 23 | PACKAGECONFIG ??= "" |
| 24 | PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt" |
| 25 | |
| 26 | inherit autotools gettext pkgconfig |
| 27 | |
| 28 | BBCLASSEXTEND = "native nativesdk" |
| 29 | |
| 30 | FILES_${PN}-dbg += "${libexecdir}/systemtap/.debug" |