blob: 5a97c8c4f635ad5a7e610ef07a64652c6e83e2ec [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001HOMEPAGE = "http://www.gevent.org"
2SUMMARY = "A coroutine-based Python networking library"
3DESCRIPTION = "\
4 gevent is a coroutine-based Python networking library that uses greenlet \
5 to provide a high-level synchronous API on top of the libevent event \
6 loop. \
7 "
8SECTION = "devel/python"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=2dbb33d00e1fd31c7041460a81ac0bd2"
11DEPENDS += "python-greenlet libevent"
12RDEPENDS_${PN} += "python-greenlet python-mime python-pprint python-re"
13
Patrick Williamsd849ec72016-08-17 14:59:38 -050014SRC_URI[md5sum] = "7b952591d1a0174d6eb6ac47bd975ab6"
15SRC_URI[sha256sum] = "4627e215d058f71d95e6b26d9e7be4c263788a4756bd2858a93775f6c072df43"
16
Mark Asselstine5fc98032017-11-14 12:55:06 -050017inherit setuptools pypi
Patrick Williamsd849ec72016-08-17 14:59:38 -050018
19FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
20SRC_URI += "file://libev-conf.patch"
21SRC_URI += "file://gevent-allow-ssl-v2-or-v3-certificates.patch"
22
23# The python-gevent has no autoreconf ability
24# and the logic for detecting a cross compile is flawed
25# so always force a cross compile
26do_configure_append() {
27 sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/libev/configure
Brad Bishop00111322018-04-01 22:23:53 -040028}