blob: f2510baa688e139e827ed71d9b9a5a1f984e6a66 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15"
16
17DEPENDS = "attr libaio libcap acl openssl zip-native"
18DEPENDS_append_libc-musl = " fts "
19EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
20EXTRA_OECONF_append_libc-musl = " LIBS=-lfts "
21
22# since ltp contains x86-64 assembler which uses the frame-pointer register,
23# set -fomit-frame-pointer x86-64 to handle cases where optimisation
24# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
25# earlier in CFLAGS, etc.
26CFLAGS_append_x86-64 = " -fomit-frame-pointer"
27
28CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
29CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050030SRCREV = "0d79a93e6ca44d9bc95973faea6bcd7b0c6d1f43"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031
32SRC_URI = "git://github.com/linux-test-project/ltp.git \
33 file://0001-build-Add-option-to-select-libc-implementation.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050034 file://0004-guard-mallocopt-with-__GLIBC__.patch \
35 file://0007-Fix-test_proc_kill-hanging.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050036 file://0001-Add-more-musl-exclusions.patch \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050037 file://0001-ptrace01-Fix-missing-format-string.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050038 file://0001-sigwaitinfo-Do-not-run-invalid-undefined-test-cases.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050039 "
40
41S = "${WORKDIR}/git"
42
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050043inherit autotools-brokensep pkgconfig
Andrew Geissler82c905d2020-04-13 13:39:40 -050044
45TARGET_CC_ARCH += "${LDFLAGS}"
46
47export prefix = "/opt/${PN}"
48export exec_prefix = "/opt/${PN}"
49
50PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
51EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
52EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite --with-open-posix-testsuite "
53# ltp network/rpc test cases ftbfs when libtirpc is found
54EXTRA_OECONF += " --without-tirpc "
55
56do_install(){
57 install -d ${D}${prefix}/
58 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
59
60 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
61 # as it lacks dependency on some perl moudle such as LWP::Simple
62 # And this script previously works as a tool for analyzing failures from LTP
63 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
64 # http://khack.osdl.org to retrieve ltp test results run on
65 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
66 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
67
68 # Copy POSIX test suite into ${D}${prefix}/testcases by manual
69 cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases
70
71 # Makefile were configured in the build system
72 find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \
73 -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
74 -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
75 -e 's@[^ ]*--sysroot=[^ "]*@@g'
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050076
77 # The controllers memcg_stree test seems to cause us hangs and takes 900s
78 # (maybe we expect more regular output?), anyhow, skip it
79 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
Andrew Geissler82c905d2020-04-13 13:39:40 -050080}
81
82RDEPENDS_${PN} = "\
83 attr \
84 bash \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050085 bc \
86 coreutils \
Andrew Geissler82c905d2020-04-13 13:39:40 -050087 cpio \
88 cronie \
89 curl \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050090 e2fsprogs \
Andrew Geissler82c905d2020-04-13 13:39:40 -050091 e2fsprogs-mke2fs \
92 expect \
93 file \
94 gawk \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050095 gdb \
Andrew Geissler82c905d2020-04-13 13:39:40 -050096 gzip \
97 iproute2 \
98 ldd \
99 libaio \
100 logrotate \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500101 net-tools \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500102 perl \
103 python3-core \
104 procps \
105 quota \
106 unzip \
107 util-linux \
108 which \
109 tar \
110"
111
112FILES_${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
113
114# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
115INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
116INSANE_SKIP_${PN} += "already-stripped staticdev"
117
118# Avoid file dependency scans, as LTP checks for things that may or may not
119# exist on the running system. For instance it has specific checks for
120# csh and ksh which are not typically part of OpenEmbedded systems (but
121# can be added via additional layers.)
122SKIP_FILEDEPS_${PN} = '1'