Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 1 | SUMMARY = "Simple, REST-API compliant daemon for automated testing" |
| 2 | DESCRIPTION = " This is a simple, REST-API compliant daemon which makes \ |
| 3 | automated testing on hardware possible by removing the need for physical \ |
| 4 | intervention as Q.A.D allows inputs to be injected via http/https requests. \ |
| 5 | This both eliminates the need to physically interact with the rig and allows \ |
| 6 | for tasks to be carried out entirely automatically." |
| 7 | |
| 8 | LICENSE = "MIT & GPL-2.0-or-later" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=402cce7fbcb6ea9ab5a0378dd7f40806 \ |
| 10 | file://openqa/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 11 | " |
| 12 | SRC_URI = "git://gitlab.com/CodethinkLabs/qad/qad;branch=main;protocol=https \ |
| 13 | file://0001-Fix-warnings-found-by-clang-compiler.patch" |
| 14 | |
| 15 | SRCREV = "ae0c099c1fdc0ca6f5d631cea6b302937122b362" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | PV = "0.0+git${SRCPV}" |
| 19 | |
| 20 | DEPENDS = "cjson libmicrohttpd libdrm libpng" |
| 21 | |
| 22 | FILES:${PN} += "qad" |
| 23 | inherit meson pkgconfig |
| 24 | |
| 25 | do_install () { |
| 26 | install -d ${D}${bindir} |
| 27 | install -p -m 755 qad ${D}${bindir}/ |
| 28 | } |