Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 1 | SUMMARY = "Andri's Main Loop" |
| 2 | DESCRIPTION = "Andri's Main Loop" |
| 3 | HOMEPAGE = "https://github.com/any1/aml" |
| 4 | LICENSE = "ISC" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=e6f3cfaa39204b96e14b68b9d50d3e4e" |
| 6 | |
| 7 | SRC_URI = "git://github.com/any1/aml;branch=master;protocol=https" |
| 8 | |
| 9 | SRCREV = "b83f3576ce4187d9285f06e9066ef43a691464d4" |
| 10 | |
| 11 | PV = "0.3.0+git${SRCPV}" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | PACKAGECONFIG ??= "" |
| 16 | PACKAGECONFIG[examples] = "-Dexamples=true,-Dexamples=false" |
| 17 | |
| 18 | PACKAGE_BEFORE_PN += "${PN}-examples" |
| 19 | ALLOW_EMPTY:${PN}-examples = "1" |
| 20 | FILES:${PN}-examples = "${bindir}" |
| 21 | |
| 22 | inherit meson pkgconfig |
| 23 | |
| 24 | AML_EXAMPLES = "ticker nested-ticker reader" |
| 25 | |
| 26 | do_install:append () { |
| 27 | if ${@bb.utils.contains('PACKAGECONFIG', 'examples', 'true', 'false', d)}; then |
| 28 | install -d ${D}${bindir} |
| 29 | for bin in ${AML_EXAMPLES}; do |
| 30 | install -m 0755 ${B}/examples/$bin ${D}${bindir} |
| 31 | done |
| 32 | fi |
| 33 | } |
| 34 | |
| 35 | BBCLASSEXTEND = "native" |