blob: 432cefcbfa27d4a153c70a3992fe5a45f90e3ad4 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
2HOMEPAGE = "https://github.com/python/mypy"
3LICENSE = "MIT & Python-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8d62fd8f8648cb018e52857347e340b9"
5
6inherit pypi python_setuptools_build_meta
7
8SRC_URI[sha256sum] = "1e280b5697202efa698372d2f39e9a6713a0395a756b1c6bd48995f8d72690dc"
9
10BBCLASSEXTEND = "native"
11
12DEPENDS += " \
13 python3-mypy-extensions-native \
14 python3-types-psutil-native \
15 python3-types-setuptools-native \
16 python3-typing-extensions-native \
17"
18
19RDEPENDS:${PN} += " \
20 python3-modules \
21 python3-mypy-extensions \
22 python3-typing-extensions \
23"