Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU Aspell spell-checker" |
| 2 | SECTION = "console/utils" |
| 3 | |
| 4 | LICENSE = "LGPLv2 | LGPLv2.1" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 6 | |
| 7 | PR = "r1" |
| 8 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | SRC_URI = "${GNU_MIRROR}/aspell/aspell-${PV}.tar.gz \ |
| 10 | file://gcc7.patch \ |
| 11 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 12 | SRC_URI[md5sum] = "e66a9c9af6a60dc46134fdacf6ce97d7" |
| 13 | SRC_URI[sha256sum] = "f52583a83a63633701c5f71db3dc40aab87b7f76b29723aeb27941eff42df6e1" |
| 14 | |
| 15 | PACKAGECONFIG ??= "" |
| 16 | PACKAGECONFIG[curses] = "--enable-curses,--disable-curses,ncurses" |
| 17 | |
| 18 | PACKAGES += "libaspell libpspell aspell-utils" |
| 19 | |
| 20 | RDEPENDS_${PN}-utils += "perl" |
| 21 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*" |
| 23 | FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*" |
| 24 | FILES_${PN} = "${bindir}/aspell" |
| 25 | FILES_libpspell = "${libdir}/libpspell.so.*" |
| 26 | FILES_${PN}-dev += "${bindir}/pspell-config" |
| 27 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 29 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 30 | ARM_INSTRUCTION_SET_armv6 = "arm" |
| 31 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 32 | inherit autotools-brokensep gettext texinfo binconfig-disabled |
| 33 | |
| 34 | BINCONFIG = "${bindir}/pspell-config" |