blob: 6171a538e5caad024e92ffc853899e589a381047 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
8
9CVE_PRODUCT = "libtiff"
10
Andrew Geissler8f840682023-07-21 09:09:43 -050011SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz"
Andrew Geissler517393d2023-01-13 08:55:19 -060012
Andrew Geissler8f840682023-07-21 09:09:43 -050013SRC_URI[sha256sum] = "d7f38b6788e4a8f5da7940c5ac9424f494d8a79eba53d555f4a507167dca5e2b"
Andrew Geissler517393d2023-01-13 08:55:19 -060014
15# exclude betas
16UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
17
Andrew Geissler8f840682023-07-21 09:09:43 -050018CVE_STATUS[CVE-2015-7313] = "fixed-version: Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 and already 4.3.0 doesn't have the issue"
Andrew Geissler517393d2023-01-13 08:55:19 -060019
20inherit autotools multilib_header
21
22CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
23
24PACKAGECONFIG ?= "cxx jpeg zlib lzma \
25 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
26
27PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
28PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
29PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
30PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
31PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
32PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
Patrick Williams864cc432023-02-09 14:54:44 -060033PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd,"
34PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate,"
Andrew Geissler517393d2023-01-13 08:55:19 -060035
36# Convert single-strip uncompressed images to multiple strips of specified
37# size (default: 8192) to reduce memory usage
38PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
39
40# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
41PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
42
43# Control picking up YCbCr subsample info. Disable to support files lacking
44# the tag
45PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
46
47# Support a mechanism allowing reading large strips (usually one strip files)
48# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
49PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
50
51PACKAGES =+ "tiffxx tiff-utils"
52FILES:tiffxx = "${libdir}/libtiffxx.so.*"
53FILES:tiff-utils = "${bindir}/*"
54
55do_install:append() {
56 oe_multilib_header tiffconf.h
57}
58
59BBCLASSEXTEND = "native nativesdk"