blob: 7cce14dba93750c2f7fad0c8515826757ac82de5 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "GNOME bluetooth manager"
2LICENSE = "GPL-2.0-only & LGPL-2.1-only"
3LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
5 file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
6"
7
8SECTION = "x11/gnome"
9
10DEPENDS = " \
11 udev \
12 libnotify \
13 libcanberra \
14 bluez5 \
15 upower \
16 gtk4 \
17 gsound \
18 libadwaita \
19"
20
21GNOMEBASEBUILDCLASS = "meson"
22GTKDOC_MESON_OPTION = "gtk_doc"
23GTKIC_VERSION = "4"
24
25inherit features_check gnomebase gtk-icon-cache gtk-doc gobject-introspection
26
27REQUIRED_DISTRO_FEATURES = "x11 opengl"
28
Andrew Geissler5082cc72023-09-11 08:41:39 -040029SRC_URI[archive.sha256sum] = "5864fe6f1e718715db26b62201b75a59020cf4247fec37645b3559cd2dba59d0"
Andrew Geissler517393d2023-01-13 08:55:19 -060030
31BT_PULSE_PACKS = " \
32 pulseaudio-lib-bluez5-util \
33 pulseaudio-module-bluetooth-discover \
34 pulseaudio-module-bluetooth-policy \
35 pulseaudio-module-bluez5-device \
36 pulseaudio-module-bluez5-discover \
37"
38
39PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)}"
40PACKAGECONFIG[pulseaudio] = ",,,${BT_PULSE_PACKS}"
41
42FILES:${PN} += "${datadir}/gnome-bluetooth-3.0"
43
44RDEPENDS:${PN} += "bluez5"