blob: 558b448baf8b2a1eea52a1d63ebe42185f1b8484 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "VPX multi-format codec"
2DESCRIPTION = "The BSD-licensed libvpx reference implementation provides en- and decoders for VP8 and VP9 bitstreams."
3HOMEPAGE = "http://www.webmproject.org/code/"
4BUGTRACKER = "http://code.google.com/p/webm/issues/list"
5SECTION = "libs/multimedia"
Brad Bishop2d39a062019-10-28 08:33:36 -04006LICENSE = "BSD-3-Clause"
Brad Bishop19323692019-04-05 15:28:33 -04007
8LIC_FILES_CHKSUM = "file://LICENSE;md5=d5b04755015be901744a78cc30d390d4"
9
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050010SRCREV = "d6eb9696aa72473c1a11d34d928d35a3acc0c9a9"
Patrick Williams03907ee2022-05-01 06:28:52 -050011SRC_URI += "git://chromium.googlesource.com/webm/libvpx;protocol=https;branch=main \
12 file://libvpx-configure-support-blank-prefix.patch \
Brad Bishop19323692019-04-05 15:28:33 -040013 "
14
15S = "${WORKDIR}/git"
16
17# ffmpeg links with this and fails
18# sysroots/armv4t-oe-linux-gnueabi/usr/lib/libvpx.a(vpx_encoder.c.o)(.text+0xc4): unresolvable R_ARM_THM_CALL relocation against symbol `memcpy@@GLIBC_2.4'
19ARM_INSTRUCTION_SET = "arm"
20
21CFLAGS += "-fPIC"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060022BUILD_LDFLAGS += "-pthread"
Brad Bishop19323692019-04-05 15:28:33 -040023
24export CC
25export LD = "${CC}"
26
Patrick Williams213cb262021-08-07 19:21:33 -050027VPXTARGET:armv5te = "armv5te-linux-gcc"
28VPXTARGET:armv6 = "armv6-linux-gcc"
Andrew Geissler5082cc72023-09-11 08:41:39 -040029VPXTARGET:armv7a = "${@bb.utils.contains("TUNE_FEATURES","neon","armv7-linux-gcc","generic-gnu",d)}"
Brad Bishop19323692019-04-05 15:28:33 -040030VPXTARGET ?= "generic-gnu"
31
32CONFIGUREOPTS = " \
33 --target=${VPXTARGET} \
34 --enable-vp9 \
35 --enable-libs \
36 --disable-install-docs \
37 --disable-static \
38 --enable-shared \
39 --prefix=${prefix} \
40 --libdir=${libdir} \
41 --size-limit=16384x16384 \
42"
43
44do_configure() {
45 ${S}/configure ${CONFIGUREOPTS}
46}
47
48do_install() {
49 oe_runmake install DESTDIR=${D}
50 chown -R root:root ${D}
51}
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060052
53BBCLASSEXTEND += "native"