blob: 4a5227f2069b51f581abab1c9299d80dfdd58d35 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Interactive Connectivity Establishment library"
2DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactive Connectivity Establishment standard (ICE)."
3HOMEPAGE = "http://nice.freedesktop.org/wiki/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE = "LGPL-2.1-only & MPL-1.1"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006LIC_FILES_CHKSUM = "file://COPYING;md5=9c42325015702feda4f4d2f19a55b767 \
7 file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
8 file://COPYING.MPL;md5=3c617710e51cdbe0fc00716f056dfb1a \
9"
10
Patrick Williamse760df82023-05-26 11:10:49 -050011SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz \
12 file://0001-agent-meson-Replace-filename-with-basename.patch"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050013SRC_URI[sha256sum] = "72e73a2acf20f59093e21d5601606e405873503eb35f346fa621de23e99b3b39"
Brad Bishop7e36d532019-09-16 07:44:26 -040014
Andrew Geissler5082cc72023-09-11 08:41:39 -040015DEPENDS = "glib-2.0 gnutls ${@bb.utils.contains('DISTRO_FEATURES', 'api-documentation', 'graphviz-native', '', d)}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016
Andrew Geissler32b11992021-03-31 13:37:05 -050017PACKAGECONFIG[gupnp] = "-Dgupnp=enabled,-Dgupnp=disabled,gupnp"
18PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0"
19PACKAGECONFIG[introspection] = "-Dintrospection=enabled,-Dintrospection=disabled,"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
Andrew Geissler32b11992021-03-31 13:37:05 -050021EXTRA_OEMESON = "-Dgstreamer=disabled"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022
Andrew Geissler32b11992021-03-31 13:37:05 -050023GTKDOC_MESON_OPTION = "gtk_doc"
24GTKDOC_MESON_ENABLE_FLAG = "enabled"
25GTKDOC_MESON_DISABLE_FLAG = "disabled"
26
27inherit meson gtk-doc gobject-introspection
Brad Bishop19323692019-04-05 15:28:33 -040028
Patrick Williams213cb262021-08-07 19:21:33 -050029FILES:${PN} += "${libdir}/gstreamer-1.0/*.so"
30FILES:${PN}-dev += "${libdir}/gstreamer-1.0/*.la"
31FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
32FILES:${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033
Patrick Williams213cb262021-08-07 19:21:33 -050034do_configure:prepend() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080035 mkdir ${S}/m4 || true
36}
37
Patrick Williams213cb262021-08-07 19:21:33 -050038do_compile:append() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080039 for i in $(find ${B} -name "*.pc") ; do
40 sed -i -e s:${STAGING_DIR_TARGET}::g \
41 -e s:/${TARGET_SYS}::g \
42 $i
43 done
44}