blob: 70c7275bc4bddc10b05e07d8d92e08758a568b06 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Simple Go-based setuid+setgid+setgroups+exec"
2HOMEPAGE = "https://github.com/tianon/gosu"
3DESCRIPTION = "This is a simple tool grown out of the simple fact that su and sudo have very strange and often annoying TTY and signal-forwarding behavior."
4LICENSE = "Apache-2.0 "
5LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7GO_IMPORT = "github.com/tianon/gosu"
8SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \
9 git://github.com/opencontainers/runc;name=runc;destsuffix=${S}/src/github.com/opencontainers/runc;branch=main;protocol=https \
10"
Patrick Williams520786c2023-06-25 16:20:36 -050011SRCREV = "0e7347714352cd7f2e5edc9d2cf838d9934e6036"
12#v1.1.0
13SRCREV_runc = "067aaf8548d78269dcb2c13b856775e27c410f9c"
Andrew Geissler5082cc72023-09-11 08:41:39 -040014
15SRCREV_FORMAT .= "_runc"
16
Andrew Geissler9aee5002022-03-30 16:27:02 +000017inherit go
18
Patrick Williams520786c2023-06-25 16:20:36 -050019CGO_ENABLED = "1"
20
Andrew Geissler9aee5002022-03-30 16:27:02 +000021do_compile:prepend() {
22 # New Go versions has Go modules support enabled by default
23 export GO111MODULE=off
24}
25
26RDEPENDS:${PN}-dev += "bash"