blob: f13925ee1857145a720e09e16acce11a23fdf43b [file] [log] [blame]
Andrew Geissler5082cc72023-09-11 08:41:39 -04001DESCRIPTION = "A library for faking the system time in user-space programs"
2SECTION = "libs"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6SRCREV = "d475b925943ad404c6c728ac868dc73949e7281c"
7
8SRC_URI = "git://github.com/wolfcw/libfaketime.git;branch=master;protocol=https \
9 file://0001-Makefile-Detect-compiler-in-makefile.patch \
10 "
11
12S = "${WORKDIR}/git"
13
14CFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE"
15
16do_configure[noexec] = "1"
17do_compile () {
18 oe_runmake
19}
20do_install () {
21 install -d ${D}${libdir}/faketime
22 oe_libinstall -C src libfaketime ${D}${libdir}/faketime
23 install -d ${D}${bindir}
24 install -m 0755 src/faketime ${D}${bindir}
25}
26
27FILES:${PN} = "${bindir}/faketime ${libdir}/faketime/lib*${SOLIBS}"
28FILES:${PN}-dev += "${libdir}/faketime/lib*${SOLIBSDEV}"