Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 1 | SUMMARY = "A simple, correct PEP517 package builder" |
| 2 | HOMEPAGE = "https://github.com/pypa/build" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=310439af287b0fb4780b2ad6907c256c" |
| 5 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 6 | SRC_URI[sha256sum] = "538aab1b64f9828977f84bc63ae570b060a8ed1be419e7870b8b4fc5e6ea553b" |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 7 | |
| 8 | inherit pypi python_flit_core |
| 9 | |
| 10 | DEPENDS += "python3-pyproject-hooks-native" |
| 11 | |
| 12 | DEPENDS:remove:class-native = "python3-build-native" |
| 13 | |
| 14 | # Skip dependencies as we're doing a minimal build to bootstrap |
| 15 | PEP517_BUILD_OPTS:class-native = "--skip-dependency-check" |
| 16 | |
| 17 | do_compile:prepend:class-native() { |
| 18 | export PYTHONPATH="${S}/src" |
| 19 | } |
| 20 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 21 | RDEPENDS:${PN} += " \ |
| 22 | python3-compression \ |
| 23 | python3-difflib \ |
| 24 | python3-ensurepip \ |
| 25 | python3-logging \ |
| 26 | python3-packaging \ |
| 27 | python3-pyproject-hooks \ |
| 28 | python3-tomllib \ |
| 29 | python3-venv \ |
| 30 | " |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |