Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "The Python Programming Language" |
| 2 | HOMEPAGE = "http://www.python.org" |
| 3 | DESCRIPTION = "Python is a programming language that lets you work more quickly and integrate your systems more effectively." |
| 4 | LICENSE = "PSF-2.0" |
| 5 | SECTION = "devel/python" |
| 6 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=fcf6b249c2641540219a727f35d8d2c2" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 8 | |
| 9 | SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \ |
| 10 | file://run-ptest \ |
| 11 | file://create_manifest3.py \ |
| 12 | file://get_module_deps3.py \ |
| 13 | file://python3-manifest.json \ |
| 14 | file://check_build_completeness.py \ |
| 15 | file://reformat_sysconfig.py \ |
| 16 | file://cgi_py.patch \ |
| 17 | file://0001-Do-not-add-usr-lib-termcap-to-linker-flags-to-avoid-.patch \ |
| 18 | ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', 'file://avoid_warning_about_tkinter.patch', d)} \ |
| 19 | file://0001-Makefile.pre-use-qemu-wrapper-when-gathering-profile.patch \ |
| 20 | file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \ |
| 21 | file://crosspythonpath.patch \ |
| 22 | file://0001-test_locale.py-correct-the-test-output-format.patch \ |
| 23 | file://0017-setup.py-do-not-report-missing-dependencies-for-disa.patch \ |
| 24 | file://0001-Makefile-do-not-compile-.pyc-in-parallel.patch \ |
| 25 | file://0020-configure.ac-setup.py-do-not-add-a-curses-include-pa.patch \ |
| 26 | file://0001-Skip-failing-tests-due-to-load-variability-on-YP-AB.patch \ |
| 27 | file://0001-test_ctypes.test_find-skip-without-tools-sdk.patch \ |
| 28 | file://makerace.patch \ |
| 29 | file://0001-sysconfig.py-use-platlibdir-also-for-purelib.patch \ |
| 30 | file://0001-Lib-pty.py-handle-stdin-I-O-errors-same-way-as-maste.patch \ |
| 31 | file://0001-setup.py-Do-not-detect-multiarch-paths-when-cross-co.patch \ |
| 32 | file://deterministic_imports.patch \ |
| 33 | file://0001-Avoid-shebang-overflow-on-python-config.py.patch \ |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 34 | file://0001-Update-test_sysconfig-for-posix_user-purelib.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 35 | " |
| 36 | |
| 37 | SRC_URI:append:class-native = " \ |
| 38 | file://0001-Lib-sysconfig.py-use-prefix-value-from-build-configu.patch \ |
| 39 | file://12-distutils-prefix-is-inside-staging-area.patch \ |
| 40 | file://0001-Don-t-search-system-for-headers-libraries.patch \ |
| 41 | " |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 42 | SRC_URI[sha256sum] = "85cd12e9cf1d6d5a45f17f7afe1cebe7ee628d3282281c492e86adf636defa3f" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 43 | |
| 44 | # exclude pre-releases for both python 2.x and 3.x |
| 45 | UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar" |
| 46 | UPSTREAM_CHECK_URI = "https://www.python.org/downloads/source/" |
| 47 | |
| 48 | CVE_PRODUCT = "python" |
| 49 | |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 50 | CVE_STATUS[CVE-2007-4559] = "disputed: Upstream consider this expected behaviour" |
| 51 | CVE_STATUS[CVE-2019-18348] = "not-applicable-config: This is not exploitable when glibc has CVE-2016-10739 fixed" |
| 52 | CVE_STATUS[CVE-2020-15523] = "not-applicable-platform: Issue only applies on Windows" |
| 53 | CVE_STATUS[CVE-2022-26488] = "not-applicable-platform: Issue only applies on Windows" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 54 | # The module will be removed in the future and flaws documented. |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 55 | CVE_STATUS[CVE-2015-20107] = "upstream-wontfix: The mailcap module is insecure by design, so this can't be fixed in a meaningful way" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 56 | CVE_STATUS[CVE-2023-36632] = "disputed: Not an issue, in fact expected behaviour" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 57 | |
| 58 | PYTHON_MAJMIN = "3.11" |
| 59 | |
| 60 | S = "${WORKDIR}/Python-${PV}" |
| 61 | |
| 62 | BBCLASSEXTEND = "native nativesdk" |
| 63 | |
| 64 | inherit autotools pkgconfig qemu ptest multilib_header update-alternatives |
| 65 | |
| 66 | MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}" |
| 67 | |
| 68 | ALTERNATIVE:${PN}-dev = "python3-config" |
| 69 | ALTERNATIVE_LINK_NAME[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config" |
| 70 | ALTERNATIVE_TARGET[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}" |
| 71 | |
| 72 | |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 73 | DEPENDS = "bzip2-replacement-native expat libffi bzip2 openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux-libuuid libtirpc libnsl2 autoconf-archive-native ncurses" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 74 | DEPENDS:append:class-target = " python3-native" |
| 75 | DEPENDS:append:class-nativesdk = " python3-native" |
| 76 | |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 77 | EXTRA_OECONF = " --without-ensurepip --enable-shared --with-platlibdir=${baselib} --with-system-expat" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 78 | EXTRA_OECONF:append:class-native = " --bindir=${bindir}/${PN}" |
| 79 | EXTRA_OECONF:append:class-target = " --with-build-python=nativepython3" |
| 80 | EXTRA_OECONF:append:class-nativesdk = " --with-build-python=nativepython3" |
| 81 | |
| 82 | export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/" |
| 83 | |
| 84 | EXTRANATIVEPATH += "python3-native" |
| 85 | |
| 86 | # LTO will be enabled via packageconfig depending upong distro features |
| 87 | LTO:class-target = "" |
| 88 | |
| 89 | CACHED_CONFIGUREVARS = " \ |
| 90 | ac_cv_file__dev_ptmx=yes \ |
| 91 | ac_cv_file__dev_ptc=no \ |
| 92 | ac_cv_working_tzset=yes \ |
| 93 | " |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 94 | # set thread stack size to 2MB on musl for interpreter and stdlib C extensions |
| 95 | # so it does not run into stack limits due to musl's small thread stack |
| 96 | # This is only needed to build interpreter and not the subsequent modules |
| 97 | # Thats why CFLAGS_NODIST is modified instead of CFLAGS |
| 98 | CACHED_CONFIGUREVARS:append:libc-musl = "\ |
| 99 | CFLAGS_NODIST='${CFLAGS} -DTHREAD_STACK_SIZE=0x200000' \ |
| 100 | " |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 101 | |
| 102 | # PGO currently causes builds to not be reproducible so disable by default, see YOCTO #13407 |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 103 | PACKAGECONFIG ??= "editline gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}" |
| 104 | PACKAGECONFIG[readline] = "--with-readline=readline,,readline,,,editline" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 105 | PACKAGECONFIG[editline] = "--with-readline=editline,,libedit,,,readline" |
| 106 | # Use profile guided optimisation by running PyBench inside qemu-user |
| 107 | PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native" |
| 108 | PACKAGECONFIG[tk] = ",,tk" |
| 109 | PACKAGECONFIG[tcl] = ",,tcl" |
| 110 | PACKAGECONFIG[gdbm] = ",,gdbm" |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 111 | PACKAGECONFIG[lto] = "--with-lto,--without-lto" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 112 | |
| 113 | do_configure:prepend () { |
| 114 | mkdir -p ${B}/Modules |
| 115 | cat > ${B}/Modules/Setup.local << EOF |
| 116 | *disabled* |
| 117 | ${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '', '_gdbm _dbm', d)} |
| 118 | ${@bb.utils.contains('PACKAGECONFIG', 'readline', '', 'readline', d)} |
| 119 | EOF |
| 120 | } |
| 121 | |
| 122 | CPPFLAGS:append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid" |
| 123 | |
| 124 | EXTRA_OEMAKE = '\ |
| 125 | STAGING_LIBDIR=${STAGING_LIBDIR} \ |
| 126 | STAGING_INCDIR=${STAGING_INCDIR} \ |
| 127 | LIB=${baselib} \ |
| 128 | ' |
| 129 | |
| 130 | do_compile:prepend:class-target() { |
| 131 | if ${@bb.utils.contains('PACKAGECONFIG', 'pgo', 'true', 'false', d)}; then |
| 132 | qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}', ['${B}', '${STAGING_DIR_TARGET}/${base_libdir}'])}" |
| 133 | cat >pgo-wrapper <<EOF |
| 134 | #!/bin/sh |
| 135 | cd ${B} |
| 136 | $qemu_binary "\$@" |
| 137 | EOF |
| 138 | chmod +x pgo-wrapper |
| 139 | fi |
| 140 | } |
| 141 | |
| 142 | do_install:prepend() { |
| 143 | ${WORKDIR}/check_build_completeness.py ${T}/log.do_compile |
| 144 | } |
| 145 | |
| 146 | do_install:append:class-target() { |
| 147 | oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h |
| 148 | } |
| 149 | |
| 150 | do_install:append:class-native() { |
| 151 | # Make sure we use /usr/bin/env python |
| 152 | for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do |
| 153 | sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT |
| 154 | done |
| 155 | # Add a symlink to the native Python so that scripts can just invoke |
| 156 | # "nativepython" and get the right one without needing absolute paths |
| 157 | # (these often end up too long for the #! parser in the kernel as the |
| 158 | # buffer is 128 bytes long). |
| 159 | ln -s python3-native/python3 ${D}${bindir}/nativepython3 |
| 160 | |
| 161 | # Remove the opt-1.pyc and opt-2.pyc files. There are over 3,000 of them |
| 162 | # and the overhead in each recipe-sysroot-native isn't worth it, particularly |
| 163 | # when they're only used for python called with -O or -OO. |
| 164 | #find ${D} -name *opt-*.pyc -delete |
| 165 | # Remove all pyc files. There are a ton of them and it is probably faster to let |
| 166 | # python create the ones it wants at runtime rather than manage in the sstate |
| 167 | # tarballs and sysroot creation. |
| 168 | find ${D} -name *.pyc -delete |
| 169 | |
| 170 | # Nothing should be looking into ${B} for python3-native |
| 171 | sed -i -e 's:${B}:/build/path/unavailable/:g' \ |
| 172 | ${D}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile |
| 173 | |
| 174 | # disable the lookup in user's site-packages globally |
| 175 | sed -i 's#ENABLE_USER_SITE = None#ENABLE_USER_SITE = False#' ${D}${libdir}/python${PYTHON_MAJMIN}/site.py |
| 176 | |
| 177 | # python3-config needs to be in /usr/bin and not in a subdir of it to work properly |
| 178 | mv ${D}/${bindir}/${PN}/python*config ${D}/${bindir}/ |
| 179 | } |
| 180 | |
| 181 | do_install:append() { |
| 182 | for c in ${D}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do |
| 183 | python3 ${WORKDIR}/reformat_sysconfig.py $c |
| 184 | done |
| 185 | rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/__pycache__/_sysconfigdata*.cpython* |
| 186 | |
| 187 | mkdir -p ${D}${libdir}/python-sysconfigdata |
| 188 | sysconfigfile=`find ${D} -name _sysconfig*.py` |
| 189 | sed -i \ |
| 190 | -e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \ |
| 191 | -e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \ |
| 192 | -e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \ |
| 193 | -e "s,^ 'INCLUDEPY'.*, 'INCLUDEPY': '${STAGING_INCDIR}/python${PYTHON_MAJMIN}'\,,g" \ |
| 194 | -e "s,^ 'CONFINCLUDEPY'.*, 'CONFINCLUDEPY': '${STAGING_INCDIR}/python${PYTHON_MAJMIN}'\,,g" \ |
| 195 | -e "s,${B},/build/path/unavailable/,g" \ |
| 196 | $sysconfigfile |
| 197 | cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py |
| 198 | |
| 199 | |
| 200 | # Unfortunately the following pyc files are non-deterministc due to 'frozenset' |
| 201 | # being written without strict ordering, even with PYTHONHASHSEED = 0 |
| 202 | # Upstream is discussing ways to solve the issue properly, until then let's |
| 203 | # just not install the problematic files. |
| 204 | # More info: http://benno.id.au/blog/2013/01/15/python-determinism |
| 205 | rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_range.cpython* |
| 206 | rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_xml_etree.cpython* |
| 207 | |
| 208 | # Similar to the above, we're getting reproducibility issues with |
| 209 | # /usr/lib/python3.10/__pycache__/traceback.cpython-310.pyc |
| 210 | # so remove it too |
| 211 | rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/__pycache__/traceback.cpython* |
| 212 | |
| 213 | # Remove the opt-1.pyc and opt-2.pyc files. They effectively waste space on embedded |
| 214 | # style targets as they're only used when python is called with the -O or -OO options |
| 215 | # which is rare. |
| 216 | find ${D} -name *opt-*.pyc -delete |
| 217 | } |
| 218 | |
| 219 | do_install:append:class-nativesdk () { |
| 220 | # Make sure we use /usr/bin/env python |
| 221 | for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do |
| 222 | sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT |
| 223 | done |
| 224 | create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1' |
| 225 | } |
| 226 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 227 | do_install_ptest:append:class-target:libc-musl () { |
| 228 | sed -i -e 's|SKIPPED_TESTS=|SKIPPED_TESTS="-x test__locale -x test_c_locale_coercion -x test_locale -x test_os test_re -x test__xxsubinterpreters -x test_threading"|' ${D}${PTEST_PATH}/run-ptest |
| 229 | } |
| 230 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 231 | SYSROOT_PREPROCESS_FUNCS:append:class-target = " provide_target_config_script" |
| 232 | SYSROOT_PREPROCESS_FUNCS:append:class-nativesdk = " provide_target_config_script" |
| 233 | |
| 234 | # This is installed into /usr/python-target-config/ and not /usr/bin |
| 235 | # because adding target sysroot's /usr/bin/ to PATH has unwanted side effects |
| 236 | # in components erroneously picking up other target executables from it |
| 237 | provide_target_config_script() { |
| 238 | install -d ${SYSROOT_DESTDIR}${prefix}/python-target-config/ |
| 239 | install ${D}/${bindir}/python3-config ${SYSROOT_DESTDIR}/${prefix}/python-target-config/ |
| 240 | install ${D}/${bindir}/python${PYTHON_MAJMIN}-config ${SYSROOT_DESTDIR}/${prefix}/python-target-config/ |
| 241 | } |
| 242 | SYSROOT_DIRS += "${prefix}/python-target-config/" |
| 243 | |
| 244 | SSTATE_SCAN_FILES += "Makefile _sysconfigdata.py" |
| 245 | SSTATE_HASHEQUIV_FILEMAP = " \ |
| 246 | populate_sysroot:*/lib*/python3*/_sysconfigdata*.py:${TMPDIR} \ |
| 247 | populate_sysroot:*/lib*/python3*/_sysconfigdata*.py:${COREBASE} \ |
| 248 | populate_sysroot:*/lib*/python3*/config-*/Makefile:${TMPDIR} \ |
| 249 | populate_sysroot:*/lib*/python3*/config-*/Makefile:${COREBASE} \ |
| 250 | populate_sysroot:*/lib*/python-sysconfigdata/_sysconfigdata.py:${TMPDIR} \ |
| 251 | populate_sysroot:*/lib*/python-sysconfigdata/_sysconfigdata.py:${COREBASE} \ |
| 252 | " |
| 253 | PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess" |
| 254 | |
| 255 | py_package_preprocess () { |
| 256 | # Remove references to buildmachine paths in target Makefile and _sysconfigdata |
| 257 | sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \ |
| 258 | -e 's|${DEBUG_PREFIX_MAP}||g' \ |
| 259 | -e 's:${HOSTTOOLS_DIR}/::g' \ |
| 260 | -e 's:${RECIPE_SYSROOT_NATIVE}::g' \ |
| 261 | -e 's:${RECIPE_SYSROOT}::g' \ |
| 262 | -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \ |
| 263 | ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile \ |
| 264 | ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \ |
| 265 | ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config |
| 266 | |
| 267 | # Reformat _sysconfigdata after modifying it so that it remains |
| 268 | # reproducible |
| 269 | for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do |
| 270 | python3 ${WORKDIR}/reformat_sysconfig.py $c |
| 271 | done |
| 272 | |
| 273 | # Recompile _sysconfigdata after modifying it |
| 274 | cd ${PKGD} |
| 275 | sysconfigfile=`find . -name _sysconfigdata_*.py` |
| 276 | ${STAGING_BINDIR_NATIVE}/python3-native/python3 \ |
| 277 | -c "from py_compile import compile; compile('$sysconfigfile')" |
| 278 | ${STAGING_BINDIR_NATIVE}/python3-native/python3 \ |
| 279 | -c "from py_compile import compile; compile('$sysconfigfile', optimize=1)" |
| 280 | ${STAGING_BINDIR_NATIVE}/python3-native/python3 \ |
| 281 | -c "from py_compile import compile; compile('$sysconfigfile', optimize=2)" |
| 282 | cd - |
| 283 | |
| 284 | mv ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX} |
| 285 | |
| 286 | #Remove the unneeded copy of target sysconfig data |
| 287 | rm -rf ${PKGD}/${libdir}/python-sysconfigdata |
| 288 | } |
| 289 | |
| 290 | # We want bytecode precompiled .py files (.pyc's) by default |
| 291 | # but the user may set it on their own conf |
| 292 | INCLUDE_PYCS ?= "1" |
| 293 | |
| 294 | python(){ |
| 295 | import collections, json |
| 296 | |
| 297 | filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json') |
| 298 | # This python changes the datastore based on the contents of a file, so mark |
| 299 | # that dependency. |
| 300 | bb.parse.mark_dependency(d, filename) |
| 301 | |
| 302 | with open(filename) as manifest_file: |
| 303 | manifest_str = manifest_file.read() |
| 304 | json_start = manifest_str.find('# EOC') + 6 |
| 305 | manifest_file.seek(json_start) |
| 306 | manifest_str = manifest_file.read() |
| 307 | python_manifest = json.loads(manifest_str, object_pairs_hook=collections.OrderedDict) |
| 308 | |
| 309 | # First set RPROVIDES for -native case |
| 310 | # Hardcoded since it cant be python3-native-foo, should be python3-foo-native |
| 311 | pn = 'python3' |
| 312 | rprovides = (d.getVar('RPROVIDES') or "").split() |
| 313 | |
| 314 | # ${PN}-misc-native is not in the manifest |
| 315 | rprovides.append(pn + '-misc-native') |
| 316 | |
| 317 | for key in python_manifest: |
| 318 | pypackage = pn + '-' + key + '-native' |
| 319 | if pypackage not in rprovides: |
| 320 | rprovides.append(pypackage) |
| 321 | |
| 322 | d.setVar('RPROVIDES:class-native', ' '.join(rprovides)) |
| 323 | |
| 324 | # Then work on the target |
| 325 | include_pycs = d.getVar('INCLUDE_PYCS') |
| 326 | |
| 327 | packages = d.getVar('PACKAGES').split() |
| 328 | pn = d.getVar('PN') |
| 329 | |
| 330 | newpackages=[] |
| 331 | for key in python_manifest: |
| 332 | pypackage = pn + '-' + key |
| 333 | |
| 334 | if pypackage not in packages: |
| 335 | # We need to prepend, otherwise python-misc gets everything |
| 336 | # so we use a new variable |
| 337 | newpackages.append(pypackage) |
| 338 | |
| 339 | # "Build" python's manifest FILES, RDEPENDS and SUMMARY |
| 340 | d.setVar('FILES:' + pypackage, '') |
| 341 | for value in python_manifest[key]['files']: |
| 342 | d.appendVar('FILES:' + pypackage, ' ' + value) |
| 343 | |
| 344 | # Add cached files |
| 345 | if include_pycs == '1': |
| 346 | for value in python_manifest[key]['cached']: |
| 347 | d.appendVar('FILES:' + pypackage, ' ' + value) |
| 348 | |
| 349 | for value in python_manifest[key]['rdepends']: |
| 350 | # Make it work with or without $PN |
| 351 | if '${PN}' in value: |
| 352 | value=value.split('-', 1)[1] |
| 353 | d.appendVar('RDEPENDS:' + pypackage, ' ' + pn + '-' + value) |
| 354 | |
| 355 | for value in python_manifest[key].get('rrecommends', ()): |
| 356 | if '${PN}' in value: |
| 357 | value=value.split('-', 1)[1] |
| 358 | d.appendVar('RRECOMMENDS:' + pypackage, ' ' + pn + '-' + value) |
| 359 | |
| 360 | d.setVar('SUMMARY:' + pypackage, python_manifest[key]['summary']) |
| 361 | |
| 362 | # Prepending so to avoid python-misc getting everything |
| 363 | packages = newpackages + packages |
| 364 | d.setVar('PACKAGES', ' '.join(packages)) |
| 365 | d.setVar('ALLOW_EMPTY:${PN}-modules', '1') |
| 366 | d.setVar('ALLOW_EMPTY:${PN}-pkgutil', '1') |
| 367 | |
| 368 | if "pgo" in d.getVar("PACKAGECONFIG").split() and not bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d): |
| 369 | bb.fatal("pgo cannot be enabled as there is no qemu-usermode support for this architecture/machine") |
| 370 | } |
| 371 | |
| 372 | # Files needed to create a new manifest |
| 373 | |
| 374 | do_create_manifest() { |
| 375 | # This task should be run with every new release of Python. |
| 376 | # We must ensure that PACKAGECONFIG enables everything when creating |
| 377 | # a new manifest, this is to base our new manifest on a complete |
| 378 | # native python build, containing all dependencies, otherwise the task |
| 379 | # wont be able to find the required files. |
| 380 | # e.g. BerkeleyDB is an optional build dependency so it may or may not |
| 381 | # be present, we must ensure it is. |
| 382 | |
| 383 | cd ${WORKDIR} |
| 384 | # This needs to be executed by python-native and NOT by HOST's python |
| 385 | nativepython3 create_manifest3.py ${PYTHON_MAJMIN} |
| 386 | cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json |
| 387 | } |
| 388 | |
| 389 | # bitbake python -c create_manifest |
| 390 | # Make sure we have native python ready when we create a new manifest |
| 391 | addtask do_create_manifest after do_patch do_prepare_recipe_sysroot |
| 392 | |
| 393 | # manual dependency additions |
| 394 | RRECOMMENDS:${PN}-core:append:class-nativesdk = " nativesdk-python3-modules" |
| 395 | RRECOMMENDS:${PN}-crypt:append:class-target = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates" |
| 396 | RRECOMMENDS:${PN}-crypt:append:class-nativesdk = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates" |
| 397 | |
| 398 | # For historical reasons PN is empty and provided by python3-modules |
| 399 | FILES:${PN} = "" |
| 400 | RPROVIDES:${PN}-modules = "${PN}" |
| 401 | |
| 402 | FILES:${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3" |
| 403 | FILES:${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}" |
| 404 | |
| 405 | # provide python-pyvenv from python3-venv |
| 406 | RPROVIDES:${PN}-venv += "${MLPREFIX}python3-pyvenv" |
| 407 | |
| 408 | # package libpython3 |
| 409 | PACKAGES =+ "libpython3 libpython3-staticdev" |
| 410 | FILES:libpython3 = "${libdir}/libpython*.so.*" |
| 411 | FILES:libpython3-staticdev += "${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}-*/libpython${PYTHON_MAJMIN}.a" |
| 412 | INSANE_SKIP:${PN}-dev += "dev-elf" |
| 413 | INSANE_SKIP:${PN}-ptest = "dev-deps" |
| 414 | |
| 415 | # catch all the rest (unsorted) |
| 416 | PACKAGES += "${PN}-misc" |
| 417 | RDEPENDS:${PN}-misc += "\ |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 418 | ${PN}-audio \ |
| 419 | ${PN}-codecs \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 420 | ${PN}-core \ |
| 421 | ${PN}-email \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 422 | ${PN}-numbers \ |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 423 | ${PN}-pickle \ |
| 424 | ${PN}-pydoc \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 425 | " |
| 426 | RDEPENDS:${PN}-modules:append:class-target = " ${MLPREFIX}python3-misc" |
| 427 | RDEPENDS:${PN}-modules:append:class-nativesdk = " ${MLPREFIX}python3-misc" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 428 | RDEPENDS:${PN}-modules:append:class-target = " ${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '${MLPREFIX}python3-gdbm', '', d)}" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 429 | FILES:${PN}-misc = "${libdir}/python${PYTHON_MAJMIN} ${libdir}/python${PYTHON_MAJMIN}/lib-dynload" |
| 430 | |
| 431 | # catch manpage |
| 432 | PACKAGES += "${PN}-man" |
| 433 | FILES:${PN}-man = "${datadir}/man" |
| 434 | |
| 435 | # See https://bugs.python.org/issue18748 and https://bugs.python.org/issue37395 |
| 436 | RDEPENDS:libpython3:append:libc-glibc = " libgcc" |
| 437 | RDEPENDS:${PN}-ctypes:append:libc-glibc = " ${MLPREFIX}ldconfig" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 438 | RDEPENDS:${PN}-ptest = "${PN}-modules ${PN}-tests ${PN}-dev ${PN}-cgitb ${PN}-zipapp unzip bzip2 libgcc tzdata coreutils sed gcc g++ binutils \ |
| 439 | locale-base-fr-fr locale-base-en-us locale-base-de-de" |
| 440 | RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-tr-tr" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 441 | RDEPENDS:${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${MLPREFIX}tk ${MLPREFIX}tk-lib', '', d)}" |
| 442 | RDEPENDS:${PN}-idle += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${PN}-tkinter ${MLPREFIX}tcl', '', d)}" |
| 443 | DEV_PKG_DEPENDENCY = "" |
| 444 | RDEPENDS:${PN}-pydoc += "${PN}-io" |
| 445 | |
| 446 | RDEPENDS:${PN}-tests:append:class-target = " ${MLPREFIX}bash" |
| 447 | RDEPENDS:${PN}-tests:append:class-nativesdk = " ${MLPREFIX}bash" |
| 448 | |
| 449 | # Python's tests contain large numbers of files we don't need in the recipe sysroots |
| 450 | SYSROOT_PREPROCESS_FUNCS += " py3_sysroot_cleanup" |
| 451 | py3_sysroot_cleanup () { |
| 452 | rm -rf ${SYSROOT_DESTDIR}${libdir}/python${PYTHON_MAJMIN}/test |
| 453 | } |