Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Performance analysis tools for Linux" |
| 2 | DESCRIPTION = "Performance counters for Linux are a new kernel-based \ |
| 3 | subsystem that provide a framework for all things \ |
| 4 | performance analysis. It covers hardware level \ |
| 5 | (CPU/PMU, Performance Monitoring Unit) features \ |
| 6 | and software features (software counters, tracepoints) \ |
| 7 | as well." |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 8 | HOMEPAGE = "https://perf.wiki.kernel.org/index.php/Main_Page" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 10 | LICENSE = "GPL-2.0-only" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | |
| 12 | PR = "r9" |
| 13 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 14 | PACKAGECONFIG ??= "python tui libunwind libtraceevent" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | PACKAGECONFIG[dwarf] = ",NO_DWARF=1" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 16 | PACKAGECONFIG[perl] = ",NO_LIBPERL=1,perl" |
| 17 | PACKAGECONFIG[python] = ",NO_LIBPYTHON=1,python3 python3-setuptools-native" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | # gui support was added with kernel 3.6.35 |
| 19 | # since 3.10 libnewt was replaced by slang |
| 20 | # to cover a wide range of kernel we add both dependencies |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 21 | PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang" |
| 22 | PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind" |
| 23 | PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 24 | PACKAGECONFIG[bfd] = ",NO_LIBBFD=1" |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 25 | PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap" |
| 26 | PACKAGECONFIG[jvmti] = ",NO_JVMTI=1" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 27 | # libaudit support would need scripting to be enabled |
| 28 | PACKAGECONFIG[audit] = ",NO_LIBAUDIT=1,audit" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | PACKAGECONFIG[manpages] = ",,xmlto-native asciidoc-native" |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 30 | PACKAGECONFIG[cap] = ",,libcap" |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 31 | PACKAGECONFIG[libtraceevent] = ",NO_LIBTRACEEVENT=1,libtraceevent" |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 32 | # Arm CoreSight |
| 33 | PACKAGECONFIG[coresight] = "CORESIGHT=1,,opencsd" |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 34 | PACKAGECONFIG[pfm4] = ",NO_LIBPFM4=1,libpfm4" |
| 35 | PACKAGECONFIG[babeltrace] = ",NO_LIBBABELTRACE=1,babeltrace" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | |
| 37 | # libunwind is not yet ported for some architectures |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | PACKAGECONFIG:remove:arc = "libunwind" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | PACKAGECONFIG:remove:riscv32 = "libunwind" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 40 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 41 | DEPENDS = " \ |
| 42 | virtual/${MLPREFIX}libc \ |
| 43 | ${MLPREFIX}elfutils \ |
| 44 | ${MLPREFIX}binutils \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 45 | bison-native flex-native xz \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 46 | " |
| 47 | |
| 48 | do_configure[depends] += "virtual/kernel:do_shared_workdir" |
| 49 | |
| 50 | PROVIDES = "virtual/perf" |
| 51 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 52 | inherit linux-kernel-base kernel-arch manpages |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 53 | |
| 54 | # needed for building the tools/perf Python bindings |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 55 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3targetconfig', '', d)} |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 56 | inherit python3-dir |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 57 | export PYTHON_SITEPACKAGES_DIR |
| 58 | |
| 59 | #kernel 3.1+ supports WERROR to disable warnings as errors |
| 60 | export WERROR = "0" |
| 61 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 62 | do_populate_lic[depends] += "virtual/kernel:do_shared_workdir" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 63 | |
| 64 | # needed for building the tools/perf Perl binding |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 65 | include ${@bb.utils.contains('PACKAGECONFIG', 'perl', 'perf-perl.inc', '', d)} |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 66 | |
| 67 | inherit kernelsrc |
| 68 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 69 | S = "${WORKDIR}/${BP}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 70 | SPDX_S = "${S}/tools/perf" |
| 71 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 72 | # The LDFLAGS is required or some old kernels fails due missing |
| 73 | # symbols and this is preferred than requiring patches to every old |
| 74 | # supported kernel. |
| 75 | LDFLAGS="-ldl -lutil" |
| 76 | |
| 77 | EXTRA_OEMAKE = '\ |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 78 | V=1 \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 79 | VF=1 \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 80 | -C ${S}/tools/perf \ |
| 81 | O=${B} \ |
| 82 | CROSS_COMPILE=${TARGET_PREFIX} \ |
| 83 | ARCH=${ARCH} \ |
| 84 | CC="${CC}" \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 85 | CCLD="${CC}" \ |
| 86 | LDSHARED="${CC} -shared" \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 87 | AR="${AR}" \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 88 | LD="${LD}" \ |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 89 | EXTRA_CFLAGS="-ldw -I${S}" \ |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 90 | YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \ |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 91 | EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 92 | perfexecdir=${libexecdir} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 93 | NO_GTK2=1 \ |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 94 | ${PACKAGECONFIG_CONFARGS} \ |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 95 | PKG_CONFIG=pkg-config \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 96 | TMPDIR="${B}" \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 97 | LIBUNWIND_DIR=${STAGING_EXECPREFIXDIR} \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 98 | ' |
| 99 | |
| 100 | EXTRA_OEMAKE += "\ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 101 | 'DESTDIR=${D}' \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 102 | 'prefix=${prefix}' \ |
| 103 | 'bindir=${bindir}' \ |
| 104 | 'sharedir=${datadir}' \ |
| 105 | 'sysconfdir=${sysconfdir}' \ |
| 106 | 'perfexecdir=${libexecdir}/perf-core' \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 107 | 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \ |
| 108 | 'sharedir=${@os.path.relpath(datadir, prefix)}' \ |
| 109 | 'mandir=${@os.path.relpath(mandir, prefix)}' \ |
| 110 | 'infodir=${@os.path.relpath(infodir, prefix)}' \ |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 111 | ${@bb.utils.contains('PACKAGECONFIG', 'python', 'PYTHON=python3 PYTHON_CONFIG=python3-config', '', d)} \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 112 | " |
| 113 | |
Brad Bishop | d5ae7d9 | 2018-06-14 09:52:03 -0700 | [diff] [blame] | 114 | # During do_configure, we might run a 'make clean'. That often breaks |
| 115 | # when done in parallel, so disable parallelism for do_configure. Note |
| 116 | # that it has to be done this way rather than by passing -j1, since |
| 117 | # perf's build system by default ignores any -j argument, but does |
| 118 | # honour a JOBS variable. |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 119 | EXTRA_OEMAKE:append:task-configure = " JOBS=1" |
Brad Bishop | d5ae7d9 | 2018-06-14 09:52:03 -0700 | [diff] [blame] | 120 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 121 | PERF_SRC ?= "Makefile \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 122 | tools/arch \ |
| 123 | tools/build \ |
| 124 | tools/include \ |
| 125 | tools/lib \ |
| 126 | tools/Makefile \ |
| 127 | tools/perf \ |
| 128 | tools/scripts \ |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 129 | scripts/ \ |
| 130 | arch/${ARCH}/Makefile \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 131 | " |
| 132 | |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 133 | PERF_EXTRA_LDFLAGS = "" |
| 134 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 135 | # MIPS N32/N64 |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 136 | PERF_EXTRA_LDFLAGS:mipsarchn32eb = "-m elf32btsmipn32" |
| 137 | PERF_EXTRA_LDFLAGS:mipsarchn32el = "-m elf32ltsmipn32" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 138 | PERF_EXTRA_LDFLAGS:mipsarchn64eb = "-m elf64btsmip" |
| 139 | PERF_EXTRA_LDFLAGS:mipsarchn64el = "-m elf64ltsmip" |
Joel Stanley | e252c31 | 2017-12-14 15:11:12 +1030 | [diff] [blame] | 140 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 141 | do_compile() { |
| 142 | # Linux kernel build system is expected to do the right thing |
| 143 | unset CFLAGS |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 144 | test -e ${S}/tools/lib/traceevent/plugins/Makefile && \ |
| 145 | sed -i -e 's|\$(libdir)/traceevent/plugins|\$(libdir)/traceevent_${KERNEL_VERSION}/plugins|g' ${S}/tools/lib/traceevent/plugins/Makefile |
| 146 | test -e ${S}/tools/perf/Makefile.config && \ |
| 147 | sed -i -e 's|\$(libdir)/traceevent/plugins|\$(libdir)/traceevent_${KERNEL_VERSION}/plugins|g' ${S}/tools/perf/Makefile.config |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 148 | oe_runmake all |
| 149 | } |
| 150 | |
| 151 | do_install() { |
| 152 | # Linux kernel build system is expected to do the right thing |
| 153 | unset CFLAGS |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 154 | oe_runmake install |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 155 | # we are checking for this make target to be compatible with older perf versions |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 156 | if ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)} && grep -q install-python_ext ${S}/tools/perf/Makefile*; then |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 157 | oe_runmake DESTDIR=${D} install-python_ext |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 158 | if [ -e ${D}${libdir}/python*/site-packages/perf-*/SOURCES.txt ]; then |
| 159 | sed -i -e 's#${WORKDIR}##g' ${D}${libdir}/python*/site-packages/perf-*/SOURCES.txt |
| 160 | fi |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 161 | fi |
| 162 | } |
| 163 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 164 | do_configure[prefuncs] += "copy_perf_source_from_kernel" |
| 165 | python copy_perf_source_from_kernel() { |
| 166 | sources = (d.getVar("PERF_SRC") or "").split() |
| 167 | src_dir = d.getVar("STAGING_KERNEL_DIR") |
| 168 | dest_dir = d.getVar("S") |
| 169 | bb.utils.mkdirhier(dest_dir) |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 170 | bb.utils.prunedir(dest_dir) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 171 | for s in sources: |
| 172 | src = oe.path.join(src_dir, s) |
| 173 | dest = oe.path.join(dest_dir, s) |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 174 | if not os.path.exists(src): |
| 175 | bb.fatal("Path does not exist: %s. Maybe PERF_SRC does not match the kernel version." % src) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 176 | if os.path.isdir(src): |
| 177 | oe.path.copyhardlinktree(src, dest) |
| 178 | else: |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 179 | src_path = os.path.dirname(s) |
| 180 | os.makedirs(os.path.join(dest_dir,src_path),exist_ok=True) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 181 | bb.utils.copyfile(src, dest) |
| 182 | } |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 183 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 184 | do_configure:prepend () { |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 185 | # If building a multlib based perf, the incorrect library path will be |
| 186 | # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 187 | # build, with a 64 bit multilib, the arch won't match and the detection of a |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 188 | # 64 bit build (and library) are not exected. To ensure that libraries are |
| 189 | # installed to the correct location, we can use the weak assignment in the |
| 190 | # config/Makefile. |
| 191 | # |
| 192 | # Also need to relocate .config-detected to $(OUTPUT)/config-detected |
| 193 | # for kernel sources that do not already do this |
| 194 | # as two builds (e.g. perf and lib32-perf from mutlilib can conflict |
| 195 | # with each other if its in the shared source directory |
| 196 | # |
| 197 | if [ -e "${S}/tools/perf/config/Makefile" ]; then |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 198 | perfconfig="${S}/tools/perf/config/Makefile" |
| 199 | fi |
| 200 | if [ -e "${S}/tools/perf/Makefile.config" ]; then |
| 201 | perfconfig="${S}/tools/perf/Makefile.config" |
| 202 | fi |
| 203 | if [ -n "${perfconfig}" ]; then |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 204 | # Match $(prefix)/$(lib) and $(prefix)/lib |
| 205 | sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \ |
| 206 | -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \ |
| 207 | -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 208 | ${perfconfig} |
| 209 | fi |
| 210 | # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)" |
| 211 | # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it |
| 212 | # will use the relative path 'share/man', in the way it will resulting in |
| 213 | # incorrect installation for man pages. |
| 214 | if [ -e "${S}/tools/perf/Documentation/Makefile" ]; then |
| 215 | sed -i 's,^mandir?=,mandir:=,' ${S}/tools/perf/Documentation/Makefile |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 216 | fi |
| 217 | if [ -e "${S}/tools/perf/Makefile.perf" ]; then |
| 218 | sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \ |
| 219 | ${S}/tools/perf/Makefile.perf |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 220 | sed -i -e "s,prefix='\$(DESTDIR_SQ)/usr'$,prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(PYTHON_SITEPACKAGES_DIR)' --root='\$(DESTDIR)',g" \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 221 | ${S}/tools/perf/Makefile.perf |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 222 | # backport https://github.com/torvalds/linux/commit/e4ffd066ff440a57097e9140fa9e16ceef905de8 |
| 223 | sed -i -e 's,\($(Q)$(SHELL) .$(arch_errno_tbl).\) $(CC) $(arch_errno_hdr_dir),\1 $(firstword $(CC)) $(arch_errno_hdr_dir),g' \ |
| 224 | ${S}/tools/perf/Makefile.perf |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 225 | fi |
| 226 | sed -i -e "s,--root='/\$(DESTDIR_SQ)',--prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \ |
Patrick Williams | d7e9631 | 2015-09-22 08:09:05 -0500 | [diff] [blame] | 227 | ${S}/tools/perf/Makefile* |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 228 | |
| 229 | if [ -e "${S}/tools/build/Makefile.build" ]; then |
| 230 | sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \ |
| 231 | ${S}/tools/build/Makefile.build |
| 232 | fi |
| 233 | |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 234 | # start reproducibility substitutions |
| 235 | if [ -e "${S}/tools/perf/Makefile.config" ]; then |
| 236 | # The following line in the Makefle: |
| 237 | # override PYTHON := $(call get-executable-or-default,PYTHON,$(PYTHON_AUTO)) |
| 238 | # "PYTHON" / "PYTHON_AUTO" have the full path as part of the variable. We've |
| 239 | # ensure that the environment is setup and we do not need the full path to be |
| 240 | # captured, since the symbol gets built into the executable, making it not |
| 241 | # reproducible. |
| 242 | sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO)),$(notdir $(call get-executable-or-default\,PYTHON\,$(PYTHON_AUTO))),g' \ |
| 243 | ${S}/tools/perf/Makefile.config |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 244 | # The same line is in older releases, but looking explicitly for Python 2 |
| 245 | sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(PYTHON2)),$(notdir $(call get-executable-or-default\,PYTHON\,$(PYTHON2))),g' \ |
| 246 | ${S}/tools/perf/Makefile.config |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 247 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 248 | # likewise with this substitution. Kernels with commit 18f2967418d031a39 |
| 249 | # [perf tools: Use Python devtools for version autodetection rather than runtime] |
| 250 | # need this substitution for reproducibility. |
| 251 | sed -i -e 's,$(call get-executable-or-default\,PYTHON\,$(subst -config\,\,$(PYTHON_AUTO))),$(notdir $(call get-executable-or-default\,PYTHON\,$(subst -config\,\,$(PYTHON_AUTO)))),g' \ |
| 252 | ${S}/tools/perf/Makefile.config |
| 253 | |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 254 | # The following line: |
| 255 | # srcdir_SQ = $(patsubst %tools/perf,tools/perf,$(subst ','\'',$(srcdir))), |
| 256 | # Captures the full src path of perf, which of course makes it not |
| 257 | # reproducible. We really only need the relative location 'tools/perf', so we |
| 258 | # change the Makefile line to remove everything before 'tools/perf' |
| 259 | sed -i -e "s%srcdir_SQ = \$(subst ','\\\'',\$(srcdir))%srcdir_SQ = \$(patsubst \%tools/perf,tools/perf,\$(subst ','\\\'',\$(srcdir)))%g" \ |
| 260 | ${S}/tools/perf/Makefile.config |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 261 | # Avoid hardcoded path to python-native |
| 262 | sed -i -e 's#\(PYTHON_WORD := \)$(call shell-wordify,$(PYTHON))#\1 python3#g' \ |
| 263 | ${S}/tools/perf/Makefile.config |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 264 | fi |
| 265 | if [ -e "${S}/tools/perf/tests/Build" ]; then |
| 266 | # OUTPUT is the full path, we have python on the path so we remove it from the |
| 267 | # definition. This is captured in the perf binary, so breaks reproducibility |
| 268 | sed -i -e 's,PYTHONPATH="BUILD_STR($(OUTPUT)python)",PYTHONPATH="BUILD_STR(python)",g' \ |
| 269 | ${S}/tools/perf/tests/Build |
| 270 | fi |
| 271 | if [ -e "${S}/tools/perf/util/Build" ]; then |
| 272 | # To avoid bison generating #ifdefs that have captured paths, we make sure |
| 273 | # all the calls have YFLAGS, which contains prefix mapping information. |
| 274 | sed -i -e 's,$(BISON),$(BISON) $(YFLAGS),g' ${S}/tools/perf/util/Build |
| 275 | fi |
| 276 | if [ -e "${S}/scripts/Makefile.host" ]; then |
| 277 | # To avoid yacc (bison) generating #ifdefs that have captured paths, we make sure |
| 278 | # all the calls have YFLAGS, which contains prefix mapping information. |
| 279 | sed -i -e 's,$(YACC),$(YACC) $(YFLAGS),g' ${S}/scripts/Makefile.host |
| 280 | fi |
| 281 | if [ -e "${S}/tools/perf/pmu-events/Build" ]; then |
| 282 | target='$(OUTPUT)pmu-events/pmu-events.c $(V)' |
| 283 | replacement1='$(OUTPUT)pmu-events/pmu-events.c $(V)\n' |
| 284 | replacement2='\t$(srctree)/sort-pmuevents.py $(OUTPUT)pmu-events/pmu-events.c $(OUTPUT)pmu-events/pmu-events.c.new\n' |
| 285 | replacement3='\tcp $(OUTPUT)pmu-events/pmu-events.c.new $(OUTPUT)pmu-events/pmu-events.c' |
| 286 | sed -i -e "s,$target,$replacement1$replacement2$replacement3,g" \ |
| 287 | "${S}/tools/perf/pmu-events/Build" |
| 288 | fi |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 289 | if [ -e "${S}/tools/perf/pmu-events/jevents.py" ]; then |
| 290 | sed -i -e "s#os.scandir(path)#sorted(os.scandir(path), key=lambda e: e.name)#g" \ |
| 291 | "${S}/tools/perf/pmu-events/jevents.py" |
| 292 | fi |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 293 | if [ -e "${S}/tools/perf/arch/arm64/Makefile" ]; then |
| 294 | sed -i 's,sysdef := $(srctree)/,sysdef := ,' ${S}/tools/perf/arch/arm64/Makefile |
| 295 | sed -i 's,$(incpath) $(sysdef),$(incpath) $(srctree)/$(sysdef) $(sysdef),' ${S}/tools/perf/arch/arm64/Makefile |
| 296 | fi |
| 297 | if [ -e "${S}/tools/perf/arch/arm64/entry/syscalls/mksyscalltbl" ]; then |
| 298 | if ! grep -q input_rel ${S}/tools/perf/arch/arm64/entry/syscalls/mksyscalltbl; then |
| 299 | sed -i 's,input=$4,input=$4\ninput_rel=$5,' ${S}/tools/perf/arch/arm64/entry/syscalls/mksyscalltbl |
| 300 | fi |
| 301 | sed -i 's,#include \\"\$input\\",#include \\"\$input_rel\\",' ${S}/tools/perf/arch/arm64/entry/syscalls/mksyscalltbl |
| 302 | fi |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 303 | # end reproducibility substitutions |
| 304 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 305 | # We need to ensure the --sysroot option in CC is preserved |
| 306 | if [ -e "${S}/tools/perf/Makefile.perf" ]; then |
| 307 | sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/perf/Makefile.perf |
| 308 | sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/perf/Makefile.perf |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 309 | sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/perf/Makefile.perf |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 310 | sed -i 's,PKG_CONFIG = $(CROSS_COMPILE)pkg-config,#PKG_CONFIG,' ${S}/tools/perf/Makefile.perf |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 311 | fi |
| 312 | if [ -e "${S}/tools/lib/api/Makefile" ]; then |
| 313 | sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile |
| 314 | sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 315 | sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/lib/api/Makefile |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 316 | fi |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 317 | if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then |
| 318 | sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile |
| 319 | sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile |
| 320 | fi |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 321 | if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then |
| 322 | sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile |
| 323 | fi |
| 324 | if [ -e "${S}/tools/build/Makefile.feature" ]; then |
| 325 | sed -i 's,CFLAGS=,CC="\$(CC)" CFLAGS=,' ${S}/tools/build/Makefile.feature |
| 326 | fi |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 327 | # The libperl feature check produces fatal warnings due to -Werror being |
| 328 | # used, silence enough errors that the check passes. |
| 329 | sed -i 's/\(FLAGS_PERL_EMBED=.*\)/\1 -Wno-error=unused-function -Wno-error=attributes/' ${S}/tools/build/feature/Makefile |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 330 | |
| 331 | # 3.17-rc1+ has a include issue for arm/powerpc. Temporarily sed in the appropriate include |
| 332 | if [ -e "${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c" ]; then |
| 333 | sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c |
| 334 | fi |
| 335 | if [ -e "${S}/tools/perf/arch/arm/util/unwind-libunwind.c" ] && [ -e "${S}/tools/perf/arch/arm/tests/dwarf-unwind.c" ]; then |
| 336 | sed -i 's,#include "tests/tests.h",#include "tests/tests.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/tests/dwarf-unwind.c |
| 337 | sed -i 's,#include "perf_regs.h",#include "perf_regs.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/util/unwind-libunwind.c |
| 338 | fi |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 339 | |
| 340 | # use /usr/bin/env instead of version specific python |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 341 | for s in `find ${S}/tools/perf/ -name '*.py'` `find ${S}/scripts/ -name 'bpf_helpers_doc.py'`; do |
| 342 | sed -i -e "s,#!.*python.*,#!${USRBINPATH}/env python3," ${s} |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 343 | done |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 344 | |
| 345 | # unistd.h can be out of sync between libc-headers and the captured version in the perf source |
| 346 | # so we copy it from the sysroot unistd.h to the perf unistd.h |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 347 | install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 348 | install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/include/uapi/asm-generic/unistd.h |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 349 | |
| 350 | # the fetcher is inhibited by the 'inherit kernelsrc', so we do a quick check and |
| 351 | # copy for a helper script we need |
| 352 | for p in $(echo ${FILESPATH} | tr ':' '\n'); do |
| 353 | if [ -e $p/sort-pmuevents.py ]; then |
| 354 | cp $p/sort-pmuevents.py ${S} |
| 355 | fi |
| 356 | done |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 357 | } |
| 358 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 359 | python do_package:prepend() { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 360 | d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0]) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 361 | } |
| 362 | |
| 363 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 364 | |
| 365 | |
| 366 | PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python" |
| 367 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 368 | RDEPENDS:${PN} += "elfutils bash" |
| 369 | RDEPENDS:${PN}-archive =+ "bash" |
| 370 | RDEPENDS:${PN}-python =+ "bash python3 python3-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python', '', d)}" |
| 371 | RDEPENDS:${PN}-perl =+ "bash perl perl-modules" |
| 372 | RDEPENDS:${PN}-tests =+ "python3 bash" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 373 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 374 | RSUGGESTS:${PN} += "${PN}-archive ${PN}-tests \ |
| 375 | ${@bb.utils.contains('PACKAGECONFIG', 'perl', '${PN}-perl', '', d)} \ |
| 376 | ${@bb.utils.contains('PACKAGECONFIG', 'python', '${PN}-python', '', d)} \ |
| 377 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 378 | FILES_SOLIBSDEV = "" |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 379 | FILES:${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent* ${libdir}/libperf-jvmti.so" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 380 | FILES:${PN}-archive = "${libdir}/perf/perf-core/perf-archive" |
| 381 | FILES:${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests" |
| 382 | FILES:${PN}-python = " \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 383 | ${PYTHON_SITEPACKAGES_DIR} \ |
| 384 | ${libexecdir}/perf-core/scripts/python \ |
| 385 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 386 | FILES:${PN}-perl = "${libexecdir}/perf-core/scripts/perl" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 387 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 388 | DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized" |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 389 | |
| 390 | PACKAGESPLITFUNCS =+ "perf_fix_sources" |
| 391 | |
| 392 | perf_fix_sources () { |
| 393 | for f in util/parse-events-flex.h util/parse-events-flex.c util/pmu-flex.c \ |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 394 | util/pmu-flex.h util/expr-flex.h util/expr-flex.c; do |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 395 | f=${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/$f |
| 396 | if [ -e $f ]; then |
| 397 | sed -i -e 's#${S}/##g' $f |
| 398 | fi |
| 399 | done |
| 400 | } |