blob: 9c1f601aabea68cb2a424ab49ba85569cb9682de [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Audio format Conversion library"
2DESCRIPTION = "Library for reading and writing files containing sampled \
3sound (such as MS Windows WAV and the Apple/SGI AIFF format) through \
4one standard library interface."
5HOMEPAGE = "https://libsndfile.github.io/libsndfile/"
Andrew Geissler517393d2023-01-13 08:55:19 -06006DEPENDS = "flac libogg libvorbis"
7SECTION = "libs/multimedia"
8LICENSE = "LGPL-2.1-only"
9
10SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/libsndfile-${PV}.tar.xz \
11 file://noopus.patch \
12 "
13GITHUB_BASE_URI = "https://github.com/libsndfile/libsndfile/releases/"
14
Andrew Geissler5082cc72023-09-11 08:41:39 -040015SRC_URI[sha256sum] = "3799ca9924d3125038880367bf1468e53a1b7e3686a934f098b7e1d286cdb80e"
Andrew Geissler517393d2023-01-13 08:55:19 -060016
17LIC_FILES_CHKSUM = "file://COPYING;md5=e77fe93202736b47c07035910f47974a"
18
19CVE_PRODUCT = "libsndfile"
20
21S = "${WORKDIR}/libsndfile-${PV}"
22
23PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}"
24PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
25PACKAGECONFIG[regtest] = "--enable-sqlite,--disable-sqlite,sqlite3"
26
27inherit autotools lib_package pkgconfig multilib_header github-releases
28
29do_install:append() {
30 oe_multilib_header sndfile.h
31}