Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Highway is a C++ library for SIMD (Single Instruction, Multiple Data)" |
| 2 | HOMEPAGE = "https://github.com/google/highway/" |
| 3 | |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2b42edef8fa55315f34f2370b4715ca9" |
| 6 | |
| 7 | inherit cmake |
| 8 | |
| 9 | SRC_URI = "git://github.com/google/highway.git;protocol=https;branch=master" |
| 10 | |
| 11 | SRCREV = "58b52a717469e62b2d9b8eaa2f5dddb44d4a4cbf" |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | EXTRA_OECMAKE = "-DBUILD_TESTING=0 -DCMAKE_BUILD_TYPE=Release" |
| 15 | CXXFLAGS:append:arm = " -mfp16-format=ieee" |
| 16 | # Option not supported with clang and its default format for __fp16 anyway with clang |
| 17 | CXXFLAGS:remove:toolchain-clang = "-mfp16-format=ieee" |