Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Perl module to manipulate and access URI strings" |
| 2 | DESCRIPTION = "This package contains the URI.pm module with friends. \ |
| 3 | The module implements the URI class. URI objects can be used to access \ |
| 4 | and manipulate the various components that make up these strings." |
| 5 | HOMEPAGE = "https://metacpan.org/dist/URI" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 8 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9944b87af51186f848ae558344aded9f" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 10 | |
| 11 | SRC_URI = "${CPAN_MIRROR}/authors/id/O/OA/OALDERS/URI-${PV}.tar.gz \ |
| 12 | file://0001-Skip-TODO-test-cases-that-fail.patch \ |
| 13 | " |
| 14 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "96265860cd61bde16e8415dcfbf108056de162caa0ac37f81eb695c9d2e0ab77" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/URI-${PV}" |
| 18 | |
| 19 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" |
| 20 | |
| 21 | inherit cpan ptest-perl |
| 22 | |
| 23 | do_compile() { |
| 24 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 25 | cpan_do_compile |
| 26 | } |
| 27 | |
| 28 | do_install:prepend() { |
| 29 | # these tests require "-T" (taint) command line option |
| 30 | rm -rf ${B}/t/cwd.t |
| 31 | rm -rf ${B}/t/file.t |
| 32 | } |
| 33 | |
| 34 | RDEPENDS:${PN} += "\ |
| 35 | perl-module-integer \ |
| 36 | perl-module-mime-base64 \ |
| 37 | " |
| 38 | |
| 39 | RDEPENDS:${PN}-ptest += " \ |
| 40 | libtest-fatal-perl \ |
| 41 | libtest-needs-perl \ |
| 42 | libtest-warnings-perl \ |
| 43 | perl-module-encode \ |
| 44 | perl-module-encode-encoding \ |
| 45 | perl-module-extutils-makemaker \ |
| 46 | perl-module-extutils-mm-unix \ |
| 47 | perl-module-file-spec-functions \ |
| 48 | perl-module-net-domain \ |
| 49 | perl-module-perlio \ |
| 50 | perl-module-perlio-encoding \ |
| 51 | perl-module-test \ |
| 52 | perl-module-test-more \ |
| 53 | perl-module-utf8 \ |
| 54 | " |
| 55 | |
| 56 | BBCLASSEXTEND = "native" |