Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 1 | DESCRIPTION = "OE helper for manipulating npm cache" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 4 | |
| 5 | SRC_URI = "\ |
| 6 | file://oe-npm-cache \ |
| 7 | " |
| 8 | |
| 9 | inherit native |
| 10 | |
| 11 | B = "${WORKDIR}/build" |
| 12 | |
| 13 | do_configure() { |
| 14 | sed -e 's!@@libdir@@!${libdir}!g' < '${WORKDIR}/oe-npm-cache' > '${B}/oe-npm-cache' |
| 15 | } |
| 16 | |
| 17 | do_install() { |
| 18 | install -D -p -m 0755 ${B}/oe-npm-cache ${D}${bindir}/oe-npm-cache |
| 19 | } |
| 20 | |
| 21 | RDEPENDS:${PN} = "nodejs-native" |