Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame^] | 1 | SUMMARY = "Universal encoding detector for Python 2 and 3" |
| 2 | HOMEPAGE = "https://pypi.org/project/chardet/" |
| 3 | LICENSE = "LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "0d62712b956bc154f85fb0a266e2a3c5913c2967e00348701b32411d6def31e5" |
| 7 | |
| 8 | # setup.py of chardet needs this. |
| 9 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" |
| 10 | |
| 11 | inherit pypi python_setuptools_build_meta |
| 12 | |
| 13 | PACKAGES =+ "${PN}-cli" |
| 14 | FILES:${PN}-cli += " \ |
| 15 | ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \ |
| 16 | " |
| 17 | |
| 18 | RDEPENDS:${PN}-cli = "${PN} " |
| 19 | |
| 20 | RDEPENDS:${PN}:class-target += " \ |
| 21 | ${PYTHON_PN}-logging \ |
| 22 | " |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |