Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "The RARP daemon." |
| 2 | DESCRIPTION = "RARP (Reverse Address Resolution Protocol) is a protocol which \ |
| 3 | allows individual devices on an IP network to get their own IP addresses from \ |
| 4 | the RARP server. Some machines (e.g. SPARC boxes) use this protocol instead \ |
| 5 | of e.g. DHCP to query their IP addresses during network bootup. \ |
| 6 | Linux kernels up to 2.2 used to provide a kernel daemon for this service, \ |
| 7 | but since 2.3 kernels it is served by this userland daemon. \ |
| 8 | You should install rarpd if you want to set up a RARP server on your \ |
| 9 | network." |
| 10 | SECTION = "System Environment/Daemons" |
| 11 | |
| 12 | SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/${BPN}/${BP}.tar.gz/be2a88f8ccddf2a40ac484cb3294fedc/${BP}.tar.gz" |
| 13 | SRC_URI[md5sum] = "be2a88f8ccddf2a40ac484cb3294fedc" |
| 14 | SRC_URI[sha256sum] = "4d6145d435a5d8b567b9798620f57f9b0a464078a1deba267958f168fbe776e6" |
| 15 | |
| 16 | SRC_URI += "file://0001-rarpd.8-add-man-file.patch \ |
| 17 | file://0002-Makefile-modify-compile-parameters.patch \ |
| 18 | file://0003-rarpd.c-bug-fix.patch \ |
| 19 | file://0004-rarpd.init-add-new-init-file.patch \ |
| 20 | file://0005-ethernet.c-remove-it.patch \ |
| 21 | file://ethers.sample \ |
| 22 | file://rarpd.service \ |
| 23 | " |
| 24 | |
| 25 | LICENSE = "GPLv2+" |
| 26 | LIC_FILES_CHKSUM = "file://rarpd.c;md5=199b20b172ea93121bc613a9c77b6931" |
| 27 | |
| 28 | S = "${WORKDIR}/${BPN}" |
| 29 | |
| 30 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 31 | |
| 32 | do_install() { |
| 33 | install -d ${D}${sysconfdir}/init.d |
| 34 | install -d ${D}${sbindir} |
| 35 | install -d ${D}${mandir}/man8 |
| 36 | install -m 755 rarpd.init ${D}${sysconfdir}/init.d/rarpd |
| 37 | install -m 755 rarpd ${D}${sbindir}/rarpd |
| 38 | install -m 644 rarpd.8 ${D}${mandir}/man8/rarpd.8 |
| 39 | install -m 644 ${WORKDIR}/ethers.sample ${D}${sysconfdir}/ethers |
| 40 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 41 | install -d ${D}${systemd_unitdir}/system |
| 42 | install -m 0644 ${WORKDIR}/rarpd.service ${D}${systemd_unitdir}/system/ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 43 | } |
| 44 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 45 | inherit systemd |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 46 | |
| 47 | SYSTEMD_PACKAGES = "${PN}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 48 | SYSTEMD_SERVICE:${PN} = "rarpd.service" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 49 | SYSTEMD_AUTO_ENABLE = "disable" |
| 50 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 51 | RDEPENDS:${PN} += "bash" |