Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Shadow utils requirements for useradd.bbclass" |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 2 | HOMEPAGE = "http://github.com/shadow-maint/shadow" |
| 3 | BUGTRACKER = "http://github.com/shadow-maint/shadow/issues" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 4 | SECTION = "base utils" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame^] | 5 | LICENSE = "BSD-3-Clause | Artistic-1.0" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://login.defs_shadow-sysroot;md5=25e2f2de4dfc8f966ac5cdfce45cd7d5" |
| 7 | |
| 8 | DEPENDS = "base-passwd" |
| 9 | |
| 10 | PR = "r3" |
| 11 | |
| 12 | # The sole purpose of this recipe is to provide the /etc/login.defs |
| 13 | # file for the target sysroot - needed so the shadow-native utilities |
| 14 | # can add custom users/groups for recipes that use inherit useradd. |
| 15 | SRC_URI = "file://login.defs_shadow-sysroot" |
| 16 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 17 | S = "${WORKDIR}" |
| 18 | |
| 19 | do_install() { |
| 20 | install -d ${D}${sysconfdir} |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 21 | install -p -m 644 ${S}/login.defs_shadow-sysroot ${D}${sysconfdir}/login.defs |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | } |
| 23 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 24 | SYSROOT_DIRS += "${sysconfdir}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 25 | |
| 26 | # don't create any packages |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 27 | # otherwise: dbus-dev depends on shadow-sysroot-dev which depends on shadow-sysroot |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | # and this has another copy of /etc/login.defs already provided by shadow |
| 29 | PACKAGES = "" |
Andrew Geissler | f034379 | 2020-11-18 10:42:21 -0600 | [diff] [blame] | 30 | |
| 31 | inherit nopackages |