Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Catfish is a handy file searching tool for linux and unix" |
| 2 | SECTION = "x11/application" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 3 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" |
| 5 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 6 | inherit xfce-app python_setuptools_build_meta gtk-icon-cache mime-xdg |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 7 | |
| 8 | DEPENDS += "python3-distutils-extra-native" |
| 9 | |
| 10 | SRC_URI[sha256sum] = "e9a99a62d10981391508dd43f3cbfa2d50a69bd6b7d1eeef7d30ba4c673dcfda" |
| 11 | |
| 12 | FILES:${PN} += "${datadir}/metainfo" |
| 13 | |
| 14 | RDEPENDS:${PN} += "python3-pygobject python3-dbus" |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 15 | |
| 16 | do_install:append() { |
| 17 | # |
| 18 | # Until catfish upstream figures out a way to overcome this buildpath issue, we need to do such adjustments here. |
| 19 | # |
| 20 | sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' ${D}${datadir}/applications/org.xfce.Catfish.desktop |
| 21 | sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/catfish_lib/catfishconfig.py |
| 22 | rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/catfish_lib/__pycache__/catfishconfig.*.pyc |
| 23 | } |