blob: 46f1b70cb739dff4278928bd8716189cbc0ba016 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Publishes & browses available services on a link according to the Zeroconf / Bonjour protocol"
2DESCRIPTION = "Bonjour, also known as zero-configuration networking, enables automatic discovery of computers, devices, and services on IP networks."
3HOMEPAGE = "http://developer.apple.com/networking/bonjour/"
4LICENSE = "Apache-2.0 & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=31c50371921e0fb731003bbc665f29bf"
6
7DEPENDS:append:libc-musl = " musl-nscd"
8
9SRC_URI = "git://github.com/apple-oss-distributions/mDNSResponder;protocol=https;branch=rel/mDNSResponder-1790 \
10 file://0001-dns-sd-Include-missing-headers.patch \
11 file://0002-make-Set-libdns_sd.so-soname-correctly.patch \
12 file://0003-mDNSShared-Drop-MacOS-specific-__block-qualifier.patch \
13 file://0004-make-Separate-TLS-targets-from-libraries.patch \
14 file://0005-mDNSCore-Fix-broken-debug-parameter.patch \
15 file://0006-make-Add-top-level-Makefile.patch \
16 file://0001-Create-subroutine-for-cleaning-recent-interfaces.patch \
17 file://0002-Create-subroutine-for-tearing-down-an-interface.patch \
18 file://0003-Track-interface-socket-family.patch \
19 file://0004-Indicate-loopback-interface-to-mDNS-core.patch \
20 file://0005-Use-list-for-changed-interfaces.patch \
21 file://0006-Handle-noisy-netlink-sockets.patch \
22 file://0007-Mark-deleted-interfaces-as-being-changed.patch \
23 file://0008-Handle-errors-from-socket-calls.patch \
Patrick Williams520786c2023-06-25 16:20:36 -050024 file://0009-remove-unneeded-headers.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060025 file://mdns.service \
26 "
Patrick Williams864cc432023-02-09 14:54:44 -060027SRCREV = "8769ab51605e465425d33d757f602ce5905ca639"
Andrew Geissler517393d2023-01-13 08:55:19 -060028
29# We install a stub Makefile in the top directory so that the various checks
30# in base.bbclass pass their tests for a Makefile, this ensures (that amongst
31# other things) the sstate checks will clean the build directory when the
32# task hashes changes.
33#
34# We can't use the approach of setting ${S} to mDNSPosix as we need
35# DEBUG_PREFIX_MAP to cover files which come from the Clients directory too.
36S = "${WORKDIR}/git"
37
38inherit github-releases manpages systemd update-rc.d
39
40PACKAGECONFIG ?= "tls \
41 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
42PACKAGECONFIG[debug] = "DEBUG=1,DEBUG=0"
43PACKAGECONFIG[ipv6] = "HAVE_IPV6=1,HAVE_IPV6=0"
44PACKAGECONFIG[manpages] = ""
45PACKAGECONFIG[tls] = ",tls=no,mbedtls"
46
47CVE_PRODUCT = "apple:mdnsresponder"
48
49# CVE-2007-0613 is not applicable as it only affects Apple products
50# i.e. ichat,mdnsresponder, instant message framework and MacOS.
51# Also, https://www.exploit-db.com/exploits/3230 shows the part of code
52# affected by CVE-2007-0613 which is not preset in upstream source code.
53# Hence, CVE-2007-0613 does not affect other Yocto implementations and
54# is not reported for other distros can be marked whitelisted.
55# Links:
56# https://vulmon.com/vulnerabilitydetails?qid=CVE-2007-0613
57# https://www.incibe-cert.es/en/early-warning/vulnerabilities/cve-2007-0613
58# https://security-tracker.debian.org/tracker/CVE-2007-0613
59# https://vulmon.com/vulnerabilitydetails?qid=CVE-2007-0613
60CVE_CHECK_IGNORE += "CVE-2007-0613"
61
62PARALLEL_MAKE = ""
63
64EXTRA_OEMAKE = "os=linux 'CC=${CCLD}' 'LD=${CCLD}' 'LINKOPTS=${LDFLAGS}' STRIP=: ${PACKAGECONFIG_CONFARGS}"
65
66# MDNS_VERSIONSTR_NODTS disables __DATE__ and __TIME__ in the version string,
67# which are fixed anyway for build reproducibility.
68TARGET_CPPFLAGS += "-DMDNS_VERSIONSTR_NODTS"
69
70TARGET_CC_ARCH += "${LDFLAGS}"
71
72MDNS_BUILDDIR = "build/${@bb.utils.contains('PACKAGECONFIG','debug','debug','prod', d)}"
73
74do_install () {
75 cd mDNSPosix
76
77 install -d ${D}${sbindir}
78 install ${MDNS_BUILDDIR}/mdnsd ${D}${sbindir}
79
80 install -d ${D}${libdir}
81 install -m 0644 ${MDNS_BUILDDIR}/libdns_sd.so ${D}${libdir}/libdns_sd.so.1
82 ln -s libdns_sd.so.1 ${D}${libdir}/libdns_sd.so
83
84 install -d ${D}${includedir}
85 install -m 0644 ../mDNSShared/dns_sd.h ${D}${includedir}
86
87 install -d ${D}${mandir}/man8
88 install -m 0644 ../mDNSShared/mDNSResponder.8 ${D}${mandir}/man8/mdnsd.8
89
90 install -d ${D}${bindir}
91 install -m 0755 ../Clients/build/dns-sd ${D}${bindir}
92
93 install -d ${D}${libdir}
94 oe_libinstall -C ${MDNS_BUILDDIR} -so libnss_mdns-0.2 ${D}${libdir}
95 ln -s libnss_mdns-0.2.so ${D}${libdir}/libnss_mdns.so.2
96
97 install -d ${D}${sysconfdir}
98 install -m 0644 nss_mdns.conf ${D}${sysconfdir}
99
100 install -d ${D}${mandir}/man5
101 install -m 0644 nss_mdns.conf.5 ${D}${mandir}/man5
102
103 install -d ${D}${mandir}/man8
104 install -m 0644 libnss_mdns.8 ${D}${mandir}/man8
105
106 install -d ${D}${systemd_system_unitdir}
107 install -m 0644 ${WORKDIR}/mdns.service ${D}${systemd_system_unitdir}
108
109 install -d ${D}${INIT_D_DIR}
110 install mdnsd.sh ${D}${INIT_D_DIR}/mdns
111}
112
113pkg_postinst:${PN} () {
114 if [ -r $D${sysconfdir}/nsswitch.conf ]; then
115 sed -e '/^hosts:/s/\s*\<mdns\>//' \
116 -e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 mdns\3\4\5/' \
117 -i $D${sysconfdir}/nsswitch.conf
118 fi
119}
120
121pkg_prerm:${PN} () {
122 if [ -r $D${sysconfdir}/nsswitch.conf ]; then
123 sed -e '/^hosts:/s/\s*\<mdns\>//' \
124 -e '/^hosts:/s/\s*mdns//' \
125 -i $D${sysconfdir}/nsswitch.conf
126 fi
127}
128
129SYSTEMD_SERVICE:${PN} = "mdns.service"
130INITSCRIPT_NAME = "mdns"
131
132FILES_SOLIBSDEV = "${libdir}/libdns_sd.so"
133FILES:${PN} += "${libdir}/libnss_mdns-0.2.so"
134
135RPROVIDES:${PN} += "libdns_sd.so"