blob: 095f906f0ce62ba6017ccfd6aff1fc981ab1877c [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A module wrapper for os.path"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
4
5SRC_URI[sha256sum] = "bea3816e1d54f4e33aac78d2031a0b0ed2f95e69db85b45d51f17df97071da69"
6
Patrick Williams8e7b46e2023-05-01 14:19:06 -05007SRC_URI += "\
Patrick Williams520786c2023-06-25 16:20:36 -05008 file://run-ptest \
Patrick Williams8e7b46e2023-05-01 14:19:06 -05009"
10
11inherit pypi python_setuptools_build_meta ptest
Andrew Geissler517393d2023-01-13 08:55:19 -060012
13DEPENDS += "python3-setuptools-scm-native"
14
Patrick Williams8e7b46e2023-05-01 14:19:06 -050015RDEPENDS:${PN} += " \
Patrick Williams520786c2023-06-25 16:20:36 -050016 python3-appdirs \
17 python3-crypt \
18 python3-io \
19 python3-numbers \
20 python3-shell \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050021"
22RDEPENDS:${PN}-ptest += " \
Patrick Williams520786c2023-06-25 16:20:36 -050023 python3-pytest \
24 python3-unittest-automake-output \
Patrick Williams8e7b46e2023-05-01 14:19:06 -050025"
26
Andrew Geissler517393d2023-01-13 08:55:19 -060027BBCLASSEXTEND = "nativesdk native"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050028
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/test
31 cp -rf ${S}/test_* ${D}${PTEST_PATH}/test/
32 install -d ${D}${PTEST_PATH}/path
33 cp -rf ${S}/path/* ${D}${PTEST_PATH}/path/
34}