Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \ |
| 2 | Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \ |
| 3 | Contributors." |
| 4 | HOMEPAGE = "https://pillow.readthedocs.io" |
| 5 | LICENSE = "MIT" |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b22dc6b663b9175820e5e03337c7596b" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 7 | |
| 8 | SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \ |
| 9 | file://0001-support-cross-compiling.patch \ |
| 10 | file://0001-explicitly-set-compile-options.patch \ |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 11 | file://run-ptest \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | " |
| 13 | SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8" |
| 14 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 15 | inherit setuptools3 ptest |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 16 | |
| 17 | PIP_INSTALL_PACKAGE = "Pillow" |
| 18 | PIP_INSTALL_DIST_PATH = "${S}/dist" |
| 19 | |
| 20 | DEPENDS += " \ |
| 21 | zlib \ |
| 22 | jpeg \ |
| 23 | tiff \ |
| 24 | freetype \ |
| 25 | lcms \ |
| 26 | openjpeg \ |
| 27 | " |
| 28 | |
| 29 | RDEPENDS:${PN} += " \ |
| 30 | ${PYTHON_PN}-misc \ |
| 31 | ${PYTHON_PN}-logging \ |
| 32 | ${PYTHON_PN}-numbers \ |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 33 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcb', '', d)} \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 34 | " |
| 35 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 36 | RDEPENDS:${PN}-ptest += " \ |
| 37 | bash \ |
| 38 | ghostscript \ |
| 39 | jpeg-tools \ |
| 40 | libwebp \ |
| 41 | ${PYTHON_PN}-core \ |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 42 | ${PYTHON_PN}-distutils \ |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 43 | ${PYTHON_PN}-image \ |
| 44 | ${PYTHON_PN}-mmap \ |
| 45 | ${PYTHON_PN}-pytest \ |
| 46 | ${PYTHON_PN}-pytest-timeout \ |
| 47 | ${PYTHON_PN}-resource \ |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 48 | ${PYTHON_PN}-unixadmin\ |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 49 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'tk', '', d)} \ |
| 50 | " |
| 51 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 52 | CVE_PRODUCT = "pillow" |
| 53 | |
| 54 | S = "${WORKDIR}/git" |
| 55 | |
| 56 | RPROVIDES:${PN} += "python3-imaging" |
| 57 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 58 | do_install_ptest() { |
| 59 | install -d ${D}${PTEST_PATH}/Tests |
| 60 | cp -rf ${S}/Tests ${D}${PTEST_PATH}/ |
| 61 | } |
| 62 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 63 | BBCLASSEXTEND = "native" |
| 64 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 65 | SRCREV = "204590600c6a8c5246d0564d3312abd6e6b0ed70" |