Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Seamless operability between C++11 and Python" |
| 2 | HOMEPAGE = "https://github.com/wjakob/pybind11" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f" |
| 5 | |
| 6 | DEPENDS = "boost" |
| 7 | |
Patrick Williams | b9af875 | 2023-01-30 13:28:01 -0600 | [diff] [blame] | 8 | SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 9 | |
Patrick Williams | b9af875 | 2023-01-30 13:28:01 -0600 | [diff] [blame] | 10 | SRCREV = "0bd8896a4010f2d91b2340570c24fa08606ec406" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 14 | EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF" |
| 15 | |
| 16 | inherit cmake setuptools3 python3native |
| 17 | |
| 18 | PIP_INSTALL_DIST_PATH = "${S}/dist" |
| 19 | PIP_INSTALL_PACKAGE = "pybind11" |
| 20 | |
| 21 | do_configure() { |
Patrick Williams | b9af875 | 2023-01-30 13:28:01 -0600 | [diff] [blame] | 22 | cmake_do_configure |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 23 | } |
| 24 | |
| 25 | do_compile() { |
Patrick Williams | b9af875 | 2023-01-30 13:28:01 -0600 | [diff] [blame] | 26 | setuptools3_do_compile |
| 27 | cmake_do_compile |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 28 | } |
| 29 | |
| 30 | do_install() { |
Patrick Williams | b9af875 | 2023-01-30 13:28:01 -0600 | [diff] [blame] | 31 | setuptools3_do_install |
| 32 | cmake_do_install |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 33 | } |
| 34 | |
| 35 | BBCLASSEXTEND = "native nativesdk" |