Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Qemu helper scripts" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 2 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 3 | RDEPENDS:${PN} = "nativesdk-qemu nativesdk-unfs3 nativesdk-pseudo \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 4 | nativesdk-python3-shell nativesdk-python3-fcntl nativesdk-python3-logging \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 5 | " |
| 6 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 7 | PR = "r9" |
| 8 | |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame^] | 9 | LIC_FILES_CHKSUM = "file://${COREBASE}/scripts/runqemu;beginline=5;endline=10;md5=ac2b489a58739c7628a2604698db5e7f" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 10 | |
| 11 | |
| 12 | SRC_URI = "file://${COREBASE}/scripts/runqemu \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | file://${COREBASE}/scripts/runqemu-addptable2image \ |
| 14 | file://${COREBASE}/scripts/runqemu-gen-tapdevs \ |
| 15 | file://${COREBASE}/scripts/runqemu-ifup \ |
| 16 | file://${COREBASE}/scripts/runqemu-ifdown \ |
| 17 | file://${COREBASE}/scripts/oe-find-native-sysroot \ |
| 18 | file://${COREBASE}/scripts/runqemu-extract-sdk \ |
| 19 | file://${COREBASE}/scripts/runqemu-export-rootfs \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 20 | " |
| 21 | |
| 22 | S = "${WORKDIR}" |
| 23 | |
| 24 | inherit nativesdk |
| 25 | |
| 26 | do_compile() { |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame^] | 27 | : |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | } |
| 29 | |
| 30 | do_install() { |
| 31 | install -d ${D}${bindir} |
| 32 | install -m 0755 ${WORKDIR}${COREBASE}/scripts/oe-* ${D}${bindir}/ |
| 33 | install -m 0755 ${WORKDIR}${COREBASE}/scripts/runqemu* ${D}${bindir}/ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 34 | } |