Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Security tool that is a wrapper for TCP daemons" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 2 | HOMEPAGE = "http://www.softpanorama.org/Net/Network_security/TCP_wrappers/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 3 | DESCRIPTION = "Tools for monitoring and filtering incoming requests for tcp \ |
| 4 | services." |
| 5 | SECTION = "console/network" |
| 6 | |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 7 | LICENSE = "BSD-1-Clause" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://DISCLAIMER;md5=071bd69cb78b18888ea5e3da5c3127fa" |
| 9 | PR ="r10" |
| 10 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | DEPENDS += "libnsl2" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 12 | |
| 13 | PACKAGES = "${PN}-dbg libwrap libwrap-doc libwrap-dev libwrap-staticdev ${PN} ${PN}-doc" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 14 | FILES:libwrap = "${base_libdir}/lib*${SOLIBS}" |
| 15 | FILES:libwrap-doc = "${mandir}/man3 ${mandir}/man5" |
| 16 | FILES:libwrap-dev = "${libdir}/lib*${SOLIBSDEV} ${includedir}" |
| 17 | FILES:libwrap-staticdev = "${libdir}/lib*.a" |
| 18 | FILES:${PN} = "${sbindir}" |
| 19 | FILES:${PN}-doc = "${mandir}/man8" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 20 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 21 | SRC_URI = "http://ftp.porcupine.org/pub/security/tcp_wrappers_${PV}.tar.gz \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | file://00_man_quoting.diff \ |
| 23 | file://01_man_portability.patch \ |
| 24 | file://05_wildcard_matching.patch \ |
| 25 | file://06_fix_gethostbyname.patch \ |
| 26 | file://10_usagi-ipv6.patch \ |
| 27 | file://11_tcpd_blacklist.patch \ |
| 28 | file://11_usagi_fix.patch \ |
| 29 | file://12_makefile_config.patch \ |
| 30 | file://13_shlib_weaksym.patch \ |
| 31 | file://14_cidr_support.patch \ |
| 32 | file://15_match_clarify.patch \ |
| 33 | file://expand_remote_port.patch \ |
| 34 | file://have_strerror.patch \ |
| 35 | file://man_fromhost.patch \ |
| 36 | file://restore_sigalarm.patch \ |
| 37 | file://rfc931.diff \ |
| 38 | file://safe_finger.patch \ |
| 39 | file://sig_fix.patch \ |
| 40 | file://siglongjmp.patch \ |
| 41 | file://socklen_t.patch \ |
| 42 | file://tcpdchk_libwrapped.patch \ |
| 43 | file://ldflags.patch \ |
| 44 | file://rename_strings_variable.patch \ |
| 45 | file://try-from.8 \ |
| 46 | file://safe_finger.8 \ |
| 47 | file://makefile-fix-parallel.patch \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 48 | file://musl-decls.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 49 | file://0001-Fix-build-with-clang.patch \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 50 | file://fix_warnings.patch \ |
| 51 | file://fix_warnings2.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 52 | file://0001-Remove-fgets-extern-declaration.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 53 | " |
| 54 | |
| 55 | SRC_URI[md5sum] = "e6fa25f71226d090f34de3f6b122fb5a" |
| 56 | SRC_URI[sha256sum] = "9543d7adedf78a6de0b221ccbbd1952e08b5138717f4ade814039bb489a4315d" |
| 57 | |
| 58 | S = "${WORKDIR}/tcp_wrappers_${PV}" |
| 59 | |
| 60 | EXTRA_OEMAKE = "'CC=${CC}' \ |
| 61 | 'AR=${AR}' \ |
| 62 | 'RANLIB=${RANLIB}' \ |
| 63 | 'REAL_DAEMON_DIR=${sbindir}' \ |
| 64 | 'STYLE=-DPROCESS_OPTIONS' \ |
| 65 | 'FACILITY=LOG_DAEMON' \ |
| 66 | 'SEVERITY=LOG_INFO' \ |
| 67 | 'BUGS=' \ |
| 68 | 'VSYSLOG=' \ |
| 69 | 'RFC931_TIMEOUT=10' \ |
| 70 | 'ACCESS=-DHOSTS_ACCESS' \ |
| 71 | 'KILL_OPT=-DKILL_IP_OPTIONS' \ |
| 72 | 'UMASK=-DDAEMON_UMASK=022' \ |
| 73 | 'NETGROUP=${EXTRA_OEMAKE_NETGROUP}' \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 74 | 'ARFLAGS=rv' \ |
| 75 | 'AUX_OBJ=weak_symbols.o' \ |
| 76 | 'TLI=' \ |
| 77 | 'COPTS=' \ |
| 78 | 'EXTRA_CFLAGS=${CFLAGS} -DSYS_ERRLIST_DEFINED -DHAVE_STRERROR -DHAVE_WEAKSYMS -D_REENTRANT -DINET6=1 -Dss_family=__ss_family -Dss_len=__ss_len'" |
| 79 | |
| 80 | EXTRA_OEMAKE_NETGROUP = "-DNETGROUP -DUSE_GETDOMAIN" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 81 | EXTRA_OEMAKE_NETGROUP:libc-musl = "-DUSE_GETDOMAIN" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 82 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 83 | EXTRA_OEMAKE:append:libc-musl = " 'LIBS='" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 84 | |
| 85 | do_compile () { |
| 86 | oe_runmake 'TABLES=-DHOSTS_DENY=\"${sysconfdir}/hosts.deny\" -DHOSTS_ALLOW=\"${sysconfdir}/hosts.allow\"' \ |
| 87 | all |
| 88 | } |
| 89 | |
| 90 | BINS = "safe_finger tcpd tcpdchk try-from tcpdmatch" |
| 91 | MANS3 = "hosts_access" |
| 92 | MANS5 = "hosts_options" |
| 93 | MANS8 = "tcpd tcpdchk tcpdmatch" |
| 94 | do_install () { |
| 95 | oe_libinstall -a libwrap ${D}${libdir} |
| 96 | oe_libinstall -C shared -so libwrap ${D}${base_libdir} |
| 97 | |
| 98 | if [ "${libdir}" != "${base_libdir}" ] ; then |
| 99 | rel_lib_prefix=`echo ${libdir} | sed 's,\(^/\|\)[^/][^/]*,..,g'` |
| 100 | libname=`readlink ${D}${base_libdir}/libwrap.so | xargs basename` |
| 101 | ln -s ${rel_lib_prefix}${base_libdir}/${libname} ${D}${libdir}/libwrap.so |
| 102 | rm -f ${D}${base_libdir}/libwrap.so |
| 103 | fi |
| 104 | |
| 105 | install -d ${D}${sbindir} |
| 106 | for b in ${BINS}; do |
| 107 | install -m 0755 $b ${D}${sbindir}/ || exit 1 |
| 108 | done |
| 109 | |
| 110 | install -d ${D}${mandir}/man3 |
| 111 | for m in ${MANS3}; do |
| 112 | install -m 0644 $m.3 ${D}${mandir}/man3/ || exit 1 |
| 113 | done |
| 114 | |
| 115 | install -d ${D}${mandir}/man5 |
| 116 | for m in ${MANS5}; do |
| 117 | install -m 0644 $m.5 ${D}${mandir}/man5/ || exit 1 |
| 118 | done |
| 119 | |
| 120 | install -d ${D}${mandir}/man8 |
| 121 | for m in ${MANS8}; do |
| 122 | install -m 0644 $m.8 ${D}${mandir}/man8/ || exit 1 |
| 123 | done |
| 124 | |
| 125 | install -m 0644 ${WORKDIR}/try-from.8 ${D}${mandir}/man8/ |
| 126 | install -m 0644 ${WORKDIR}/safe_finger.8 ${D}${mandir}/man8/ |
| 127 | |
| 128 | install -d ${D}${includedir} |
| 129 | install -m 0644 tcpd.h ${D}${includedir}/ |
| 130 | |
| 131 | install -d ${D}${sysconfdir} |
| 132 | touch ${D}${sysconfdir}/hosts.allow |
| 133 | touch ${D}${sysconfdir}/hosts.deny |
| 134 | } |
| 135 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 136 | FILES:${PN} += "${sysconfdir}/hosts.allow ${sysconfdir}/hosts.deny" |