Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Audio format Conversion library" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "Library for reading and writing files containing sampled \ |
| 3 | sound (such as MS Windows WAV and the Apple/SGI AIFF format) through \ |
| 4 | one standard library interface." |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 5 | HOMEPAGE = "http://www.mega-nerd.com/libsndfile" |
| 6 | AUTHOR = "Erik de Castro Lopo" |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 7 | DEPENDS = "flac libogg libvorbis" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 8 | SECTION = "libs/multimedia" |
| 9 | LICENSE = "LGPLv2.1" |
| 10 | |
| 11 | SRC_URI = "http://www.mega-nerd.com/libsndfile/files/libsndfile-${PV}.tar.gz \ |
| 12 | file://CVE-2017-6892.patch \ |
| 13 | file://CVE-2017-8361-8365.patch \ |
| 14 | file://CVE-2017-8362.patch \ |
| 15 | file://CVE-2017-8363.patch \ |
Brad Bishop | 220d553 | 2018-08-14 00:59:39 +0100 | [diff] [blame] | 16 | file://CVE-2017-14634.patch \ |
Brad Bishop | 004d499 | 2018-10-02 23:54:45 +0200 | [diff] [blame] | 17 | file://CVE-2018-13139.patch \ |
Brad Bishop | 977dc1a | 2019-02-06 16:01:43 -0500 | [diff] [blame] | 18 | file://0001-a-ulaw-fix-multiple-buffer-overflows-432.patch \ |
Brad Bishop | f8caae3 | 2019-03-25 13:13:56 -0400 | [diff] [blame] | 19 | file://CVE-2018-19432.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | file://CVE-2017-12562.patch \ |
| 21 | file://CVE-2018-19758.patch \ |
| 22 | file://CVE-2019-3832.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 23 | " |
| 24 | |
| 25 | SRC_URI[md5sum] = "646b5f98ce89ac60cdb060fcd398247c" |
| 26 | SRC_URI[sha256sum] = "1ff33929f042fa333aed1e8923aa628c3ee9e1eb85512686c55092d1e5a9dfa9" |
| 27 | |
| 28 | LIC_FILES_CHKSUM = "file://COPYING;md5=e77fe93202736b47c07035910f47974a" |
| 29 | |
| 30 | CVE_PRODUCT = "libsndfile" |
| 31 | |
| 32 | S = "${WORKDIR}/libsndfile-${PV}" |
| 33 | |
| 34 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}" |
| 35 | PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib" |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 36 | PACKAGECONFIG[regtest] = "--enable-sqlite,--disable-sqlite,sqlite3" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 37 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 38 | inherit autotools lib_package pkgconfig multilib_header |
| 39 | |
| 40 | do_install_append() { |
| 41 | oe_multilib_header sndfile.h |
| 42 | } |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 43 | |
| 44 | # This can't be replicated and is just a memory leak. |
| 45 | # https://github.com/erikd/libsndfile/issues/398 |
| 46 | CVE_CHECK_WHITELIST += "CVE-2018-13419" |