blob: 8974bdc1f1a6ce94e0bedf468cf30b097668388c [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
2DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
3OS-independent reference implementation of the Advanced Configuration and \
4Power Interface Specification (ACPI). ACPICA code contains those portions of \
5ACPI meant to be directly integrated into the host OS as a kernel-resident \
6subsystem, and a small set of tools to assist in developing and debugging \
7ACPI tables."
8
Patrick Williams2a254922023-08-11 09:48:11 -05009HOMEPAGE = "https://www.intel.com/content/www/us/en/developer/topic-technology/open/acpica/overview.html"
Andrew Geissler595f6302022-01-24 19:11:47 +000010SECTION = "console/tools"
11
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000012LICENSE = "Intel | BSD-3-Clause | GPL-2.0-only"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050013LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=79a69059b499bccc70a484459549758f"
Andrew Geissler595f6302022-01-24 19:11:47 +000014
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16
17DEPENDS = "m4-native flex-native bison-native"
18
Patrick Williams2a254922023-08-11 09:48:11 -050019SRC_URI = "https://downloadmirror.intel.com/783534/acpica-unix-${PV}.tar.gz"
Andrew Geissler8f840682023-07-21 09:09:43 -050020SRC_URI[sha256sum] = "86876a745e3d224dcfd222ed3de465b47559e85811df2db9820ef09a9dff5cce"
Andrew Geissler595f6302022-01-24 19:11:47 +000021
Patrick Williams2a254922023-08-11 09:48:11 -050022UPSTREAM_CHECK_URI = "https://www.intel.com/content/www/us/en/download/776303/acpi-component-architecture-downloads-unix-format-source-code-and-build-environment-with-an-intel-license.html"
23UPSTREAM_VERSION_UNKNOWN = "1"
Andrew Geissler595f6302022-01-24 19:11:47 +000024
25S = "${WORKDIR}/acpica-unix-${PV}"
26
27inherit update-alternatives
28
29ALTERNATIVE_PRIORITY = "100"
30ALTERNATIVE:${PN} = "acpixtract acpidump"
31
32EXTRA_OEMAKE = "CC='${CC}' \
33 OPT_CFLAGS=-Wall \
34 DESTDIR=${D} \
35 PREFIX=${prefix} \
36 INSTALLDIR=${bindir} \
37 INSTALLFLAGS= \
38 YACC=bison \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060039 YFLAGS='-y --file-prefix-map=${WORKDIR}=${TARGET_DBGSRC_DIR}' \
Andrew Geissler595f6302022-01-24 19:11:47 +000040 "
41
42do_install() {
43 oe_runmake install
44}
45
46# iasl*.bb is a subset of this recipe, so RREPLACE it
47PROVIDES = "iasl"
48RPROVIDES:${PN} += "iasl"
49RREPLACES:${PN} += "iasl"
50RCONFLICTS:${PN} += "iasl"
51
Patrick Williamsac13d5f2023-11-24 18:59:46 -060052BBCLASSEXTEND = "native nativesdk"