Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require icu.inc |
| 2 | |
| 3 | LIC_FILES_CHKSUM = "file://../license.html;md5=64eff4aadff4d104d6d437c4fde0e6d7" |
| 4 | |
| 5 | def icu_download_version(d): |
| 6 | pvsplit = d.getVar('PV', True).split('.') |
| 7 | return pvsplit[0] + "_" + pvsplit[1] |
| 8 | |
| 9 | ICU_PV = "${@icu_download_version(d)}" |
| 10 | |
| 11 | BASE_SRC_URI = "http://download.icu-project.org/files/icu4c/${PV}/icu4c-${ICU_PV}-src.tgz" |
| 12 | SRC_URI = "${BASE_SRC_URI} \ |
| 13 | file://icu-pkgdata-large-cmd.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI_append_class-target = "\ |
| 17 | file://0001-Disable-LDFLAGSICUDT-for-Linux.patch \ |
| 18 | " |
| 19 | SRC_URI[md5sum] = "e2d523df79d6cb7855c2fbe284f4db29" |
| 20 | SRC_URI[sha256sum] = "e16b22cbefdd354bec114541f7849a12f8fc2015320ca5282ee4fd787571457b" |
| 21 | |