Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Name Service Switch module for Multicast DNS (zeroconf) name resolution" |
| 2 | HOMEPAGE = "http://0pointer.de/lennart/projects/nss-mdns/" |
| 3 | SECTION = "libs" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1+" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1" |
| 7 | |
| 8 | DEPENDS = "avahi" |
| 9 | PR = "r7" |
| 10 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 11 | SRC_URI = "http://0pointer.de/lennart/projects/nss-mdns/nss-mdns-${PV}.tar.gz \ |
| 12 | file://0001-check-for-nss.h.patch \ |
| 13 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | |
| 15 | SRC_URI[md5sum] = "03938f17646efbb50aa70ba5f99f51d7" |
| 16 | SRC_URI[sha256sum] = "1e683c2e7c3921814706d62fbbd3e9cbf493a75fa00255e0e715508d8134fa6d" |
| 17 | |
| 18 | S = "${WORKDIR}/nss-mdns-${PV}" |
| 19 | |
| 20 | inherit autotools |
| 21 | |
| 22 | EXTRA_OECONF = "--libdir=${base_libdir} --disable-lynx --enable-avahi" |
| 23 | |
| 24 | # suppress warning, but don't bother with autonamer |
| 25 | LEAD_SONAME = "libnss_mdns.so" |
| 26 | DEBIANNAME_${PN} = "libnss-mdns" |
| 27 | |
| 28 | RDEPENDS_${PN} = "avahi-daemon" |
| 29 | |
| 30 | pkg_postinst_${PN} () { |
| 31 | sed -e '/^hosts:/s/\s*\<mdns\>//' \ |
| 32 | -e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 mdns4_minimal [NOTFOUND=return]\3\4 mdns\5/' \ |
| 33 | -i $D${sysconfdir}/nsswitch.conf |
| 34 | } |
| 35 | |
| 36 | pkg_prerm_${PN} () { |
| 37 | sed -e '/^hosts:/s/\s*\<mdns\>//' \ |
| 38 | -e '/^hosts:/s/\s*mdns4_minimal\s\+\[NOTFOUND=return\]//' \ |
| 39 | -i $D${sysconfdir}/nsswitch.conf |
| 40 | } |