Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Linux Test Project" |
| 2 | DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features." |
| 3 | HOMEPAGE = "http://ltp.sourceforge.net" |
| 4 | SECTION = "console/utils" |
| 5 | LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause" |
| 6 | LIC_FILES_CHKSUM = "\ |
| 7 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 8 | file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ |
| 9 | file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \ |
| 10 | file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \ |
| 11 | file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \ |
| 12 | file://testcases/open_posix_testsuite/COPYING;md5=216e43b72efbe4ed9017cc19c4c68b01 \ |
| 13 | file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \ |
| 14 | file://tools/netpipe-2.4/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \ |
| 15 | file://tools/netpipe-2.4-ipv6/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \ |
| 16 | file://tools/top-LTP/proc/COPYING;md5=aefc88eb8a41672fbfcfe6b69ab8c49c \ |
| 17 | file://tools/pounder21/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 18 | file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 19 | file://utils/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \ |
| 20 | " |
| 21 | |
| 22 | DEPENDS = "attr libaio libcap acl openssl zip-native" |
| 23 | DEPENDS_append_libc-musl = " fts " |
| 24 | EXTRA_OEMAKE_append_libc-musl = " LIBC=musl " |
| 25 | CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__" |
| 26 | CFLAGS_append_mips64 = " -D__SANE_USERSPACE_TYPES__" |
| 27 | SRCREV = "fce797676b14f50406718e7ef640b50da66c9b36" |
| 28 | |
| 29 | SRC_URI = "git://github.com/linux-test-project/ltp.git \ |
| 30 | file://0001-ltp-Don-t-link-against-libfl.patch \ |
| 31 | file://0002-Add-knob-to-control-whether-numa-support-should-be-c.patch \ |
| 32 | file://0003-Add-knob-to-control-tirpc-support.patch \ |
| 33 | file://0004-build-Add-option-to-select-libc-implementation.patch \ |
| 34 | file://0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch \ |
| 35 | file://0006-sendfile-Use-off64_t-instead-of-__off64_t.patch \ |
| 36 | file://0007-replace-SIGCLD-with-SIGCHLD.patch \ |
| 37 | file://0008-Check-if-__GLIBC_PREREQ-is-defined-before-using-it.patch \ |
| 38 | file://0009-Guard-error.h-with-__GLIBC__.patch \ |
| 39 | file://0010-replace-__BEGIN_DECLS-and-__END_DECLS.patch \ |
| 40 | file://0011-Rename-sigset-variable-to-sigset1.patch \ |
| 41 | file://0012-fsstress.c-Replace-__int64_t-with-int64_t.patch \ |
| 42 | file://0013-include-fcntl.h-for-getting-O_-definitions.patch \ |
| 43 | file://0014-hyperthreading-Include-sys-types.h-for-pid_t-definit.patch \ |
| 44 | file://0015-mincore01-Rename-PAGESIZE-to-pagesize.patch \ |
| 45 | file://0016-ustat-Change-header-from-ustat.h-to-sys-ustat.h.patch \ |
| 46 | file://0017-replace-sigval_t-with-union-sigval.patch \ |
| 47 | file://0018-guard-mallocopt-with-__GLIBC__.patch \ |
| 48 | file://0019-tomoyo-Replace-canonicalize_file_name-with-realpath.patch \ |
| 49 | file://0020-getdents-define-getdents-getdents64-only-for-glibc.patch \ |
| 50 | file://0021-Define-_GNU_SOURCE-for-MREMAP_MAYMOVE-definition.patch \ |
| 51 | file://0022-include-sys-types.h.patch \ |
| 52 | file://0023-ptrace-Use-int-instead-of-enum-__ptrace_request.patch \ |
| 53 | file://0024-rt_sigaction-rt_sigprocmark-Define-_GNU_SOURCE.patch \ |
| 54 | file://0025-mc_gethost-include-sys-types.h.patch \ |
| 55 | file://0026-crash01-Define-_GNU_SOURCE.patch \ |
| 56 | file://0027-sysconf01-Use-_SC_2_C_VERSION-conditionally.patch \ |
| 57 | file://0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch \ |
| 58 | file://0029-trace_shed-Fix-build-with-musl.patch \ |
| 59 | file://0030-lib-Use-PTHREAD_MUTEX_RECURSIVE-in-place-of-PTHREAD_.patch \ |
| 60 | file://0031-vma03-fix-page-size-offset-as-per-page-size-alignmen.patch \ |
| 61 | file://0032-regen.sh-Include-asm-unistd.h-explicitly.patch \ |
| 62 | file://0033-shmat1-Cover-GNU-specific-code-under-__USE_GNU.patch \ |
| 63 | file://0034-periodic_output.patch \ |
| 64 | file://0035-fix-test_proc_kill-hang.patch \ |
| 65 | " |
| 66 | |
| 67 | S = "${WORKDIR}/git" |
| 68 | |
| 69 | inherit autotools-brokensep |
| 70 | |
| 71 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 72 | |
| 73 | export prefix = "/opt/ltp" |
| 74 | export exec_prefix = "/opt/ltp" |
| 75 | |
| 76 | PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl," |
| 77 | EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4" |
| 78 | EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite " |
| 79 | # ltp network/rpc test cases ftbfs when libtirpc is found |
| 80 | EXTRA_OECONF += " --without-tirpc " |
| 81 | |
| 82 | # The makefiles make excessive use of make -C and several include testcases.mk |
| 83 | # which triggers a build of the syscall header. To reproduce, build ltp, |
| 84 | # then delete the header, then "make -j XX" and watch regen.sh run multiple |
| 85 | # times. Its easier to generate this once here instead. |
| 86 | do_compile_prepend () { |
| 87 | ( make -C ${B}/testcases/kernel include/linux_syscall_numbers.h ) |
| 88 | } |
| 89 | |
| 90 | do_install(){ |
| 91 | install -d ${D}/opt/ltp/ |
| 92 | oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install |
| 93 | |
| 94 | # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual |
| 95 | cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases |
| 96 | } |
| 97 | |
| 98 | RDEPENDS_${PN} = "perl e2fsprogs-mke2fs python-core libaio bash gawk expect ldd" |
| 99 | |
| 100 | FILES_${PN}-staticdev += "/opt/ltp/lib/libmem.a" |
| 101 | |
| 102 | FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/*" |
| 103 | |
| 104 | # Avoid generated binaries stripping. Otherwise some of the ltp tests such as ldd01 & nm01 fails |
| 105 | INHIBIT_PACKAGE_STRIP = "1" |
| 106 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
| 107 | # However, test_arch_stripped is already stripped, so... |
| 108 | INSANE_SKIP_${PN} += "already-stripped" |
| 109 | |