Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Perl module for reporting the search path for a class's ISA tree" |
| 2 | DESCRIPTION = "Suppose you have a class (like Food::Fish::Fishstick) that is derived, \ |
| 3 | via its @ISA, from one or more superclasses (as Food::Fish::Fishstick is from Food::Fish,\ |
| 4 | Life::Fungus, and Chemicals), and some of those superclasses may themselves each be\ |
| 5 | derived, via its @ISA, from one or more superclasses (as above).\ |
| 6 | \ |
| 7 | When, then, you call a method in that class ($fishstick->calories), Perl first searches\ |
| 8 | there for that method, but if it's not there, it goes searching in its superclasses, and\ |
| 9 | so on, in a depth-first (or maybe "height-first" is the word) search. In the above example,\ |
| 10 | it'd first look in Food::Fish, then Food, then Matter, then Life::Fungus, then Life, then\ |
| 11 | Chemicals.\ |
| 12 | \ |
| 13 | This library, Class::ISA, provides functions that return that list -- the list\ |
| 14 | (in order) of names of classes Perl would search to find a method, with no duplicates." |
| 15 | |
| 16 | HOMEPAGE = "http://search.cpan.org/dist/Class-ISA/" |
| 17 | SECTION = "libs" |
| 18 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 19 | |
| 20 | LIC_FILES_CHKSUM = "file://README;beginline=107;endline=111;md5=6a5c6842a63cfe4dab1f66e2350e4d25" |
| 21 | |
| 22 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SM/SMUELLER/Class-ISA-${PV}.tar.gz" |
| 23 | |
| 24 | SRC_URI[md5sum] = "3a2ad203c8dc87d6c9de16215d00af47" |
| 25 | SRC_URI[sha256sum] = "8816f34e9a38e849a10df756030dccf9fe061a196c11ac3faafd7113c929b964" |
| 26 | |
| 27 | S = "${WORKDIR}/Class-ISA-${PV}" |
| 28 | |
| 29 | inherit cpan |
| 30 | |
| 31 | BBCLASSEXTEND = "native" |