Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Gummiboot is a simple UEFI boot manager which executes configured EFI images." |
| 2 | HOMEPAGE = "http://freedesktop.org/wiki/Software/gummiboot" |
| 3 | |
| 4 | LICENSE = "LGPLv2.1" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c" |
| 6 | |
| 7 | DEPENDS = "gnu-efi util-linux" |
| 8 | |
| 9 | inherit autotools pkgconfig |
| 10 | inherit deploy |
| 11 | |
| 12 | PV = "48+git${SRCPV}" |
| 13 | SRCREV = "2bcd919c681c952eb867ef1bdb458f1bc49c2d55" |
| 14 | SRC_URI = "git://anongit.freedesktop.org/gummiboot \ |
| 15 | file://fix-objcopy.patch \ |
| 16 | " |
| 17 | |
| 18 | # Note: Add COMPATIBLE_HOST here is only because it depends on gnu-efi |
| 19 | # which has set the COMPATIBLE_HOST, the gummiboot itself may work on |
| 20 | # more hosts. |
| 21 | COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux" |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | EXTRA_OECONF = "--disable-manpages --with-efi-includedir=${STAGING_INCDIR} \ |
| 26 | --with-efi-ldsdir=${STAGING_LIBDIR} \ |
| 27 | --with-efi-libdir=${STAGING_LIBDIR}" |
| 28 | |
| 29 | EXTRA_OEMAKE += "gummibootlibdir=${libdir}/gummiboot" |
| 30 | |
| 31 | do_deploy () { |
| 32 | install ${B}/gummiboot*.efi ${DEPLOYDIR} |
| 33 | } |
| 34 | addtask deploy before do_build after do_compile |